aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-14 12:28:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-20 13:16:22 +0000
commit3224b028e70ab3a910ce4fccdd9f3fac4e37011f (patch)
treeb6922796cd5bd2bf8f6075520b01b91a70f536b5 /recipes-qt/qt5/nativesdk-qtbase_git.bb
parent66c49f8a1d4ab5ab37a977c4234f58ea8ceb6053 (diff)
nativesdk-qtbase: use default PACKAGES
* don't append -tools to all packages * fixes automatic packaging of .debug files in ${PN}-dbg Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb18
1 files changed, 3 insertions, 15 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 5bea3c89..96d3e055 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -55,34 +55,22 @@ SRC_URI += " \
file://OEQt5Toolchain.cmake \
"
-PACKAGES = "${PN}-tools-dev ${PN}-tools-staticdev ${PN}-tools"
-
PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
-FILES_${PN}-tools-dev = " \
- ${includedir} \
- ${FILES_SOLIBSDEV} ${libdir}/*.la \
- ${libdir}/*.prl \
+FILES_${PN}-dev += " \
${OE_QMAKE_PATH_ARCHDATA}/mkspecs \
${OE_QMAKE_PATH_LIBS}/*.prl \
"
-FILES_${PN}-tools-staticdev = " \
- ${OE_QMAKE_PATH_LIBS}/*.a \
-"
-
-FILES_${PN}-tools = " \
- ${libdir}/lib*${SOLIBS} \
- ${OE_QMAKE_PATH_BINS}/* \
+FILES_${PN} += " \
${SDKPATHNATIVE}/environment-setup.d \
- ${datadir}/cmake \
"
# qttools binaries are placed in a subdir of bin in order to avoid
# collisions with qt4. This would trigger debian.bbclass to rename the
# package, since it doesn't detect binaries in subdirs. Explicitly
# disable package auto-renaming for the tools-package.
-DEBIAN_NOAUTONAME_${PN}-tools = "1"
+DEBIAN_NOAUTONAME_${PN} = "1"
QT_CONFIG_FLAGS += " \
-shared \