aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2018-01-08 06:52:07 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2018-01-15 17:55:20 +0000
commit34a3a4bf4b58ea7e63ff81eaf35963cbd4cf59b5 (patch)
treebb5d34eee52585bbd9ea3833d42f78abe3328b8c /recipes-qt/qt5/nativesdk-qtbase_git.bb
parentf5cb85e6293e1f742d77959cd1d7e42d536b259f (diff)
qtbase: fix a regression
A flaw was introduced by commit b8a236df: [ qt5: Fix cmake config files ] Removing ${S}/include must be done before configure script being called, but it's not in that case for qtbase-native recipe after the commit, that is saying, ${S}/include was removed after configure being called, which causes compiling issues for native build. Further more, the logic introduced by commit b8a236df should only apply to qtbase recipes, so they should be moved to qtbase recipes as well. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 3aeb2ab1..4f4a0c30 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -102,6 +102,11 @@ OE_QMAKE_PATH_HOST_LIBS = "${libdir}"
deltask generate_qt_config_file
do_configure() {
+ # Regenerate header files when they are included in source tarball
+ # Otherwise cmake files don't set PRIVATE_HEADERS correctly
+ rm -rf ${S}/include
+ mkdir -p ${S}/.git || true
+
${S}/configure -v \
-${QT_EDITION} -confirm-license \
-sysroot ${STAGING_DIR_TARGET} \