aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qt3d_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-12 18:04:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-14 18:54:55 +0100
commitfd8fc6ffdb2e34b2921f06644264c405eee94f5d (patch)
tree72ac2c5f068ab28f41316408313a8b5f4ce003fd /recipes-qt/qt5/qt3d_git.bb
parent909858baf064216a3b221edb59b40cc93d536a44 (diff)
qt3d: support qgltf in native and nativesdk builds
qgltf is used to import a variety of 3D model formats and export into fast-to-load, optimized glTF assets embedded into Qt resource files Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qt3d_git.bb')
-rw-r--r--recipes-qt/qt5/qt3d_git.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 0ec99c61..a19422b6 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -8,7 +8,19 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.GPL;md5=05832301944453ec79e40ba3c3cfceec \
"
-DEPENDS = "qtdeclarative"
+DEPENDS += "qtbase"
+DEPENDS_class-target += "qtdeclarative qt3d-native"
+
+SRC_URI += " \
+ file://0001-Allow-a-tools-only-build.patch \
+ "
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_class-native ??= "tools-only"
+PACKAGECONFIG_class-nativesdk ??= "tools-only"
+PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
+
+EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/*/*/*.bez \
@@ -16,3 +28,5 @@ FILES_${PN}-qmlplugins += " \
"
SRCREV = "9b9f34701f47824e8201453d148152fb0855f98a"
+
+BBCLASSEXTEND += "native nativesdk"