aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qt5-creator_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-10 18:39:52 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 00:55:36 +0000
commit7016481c80f79e2985a87e0188ce8110568256a8 (patch)
tree7ff367f9655c8928db7547e04544a60b6279b4c9 /recipes-qt/qt5/qt5-creator_git.bb
parentba03a767a402773dabcec14e9ccd0f9ca7cc29dd (diff)
qt5-creator: Enable clang plugin support when clang is used as toolchain
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qt5-creator_git.bb')
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 446a8adf..344c956e 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -14,7 +14,8 @@ LIC_FILES_CHKSUM = " \
inherit qmake5
-DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg"
+DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native"
+DEPENDS_append_toolchain-clang = " clang llvm-common"
DEPENDS_append_libc-musl = " libexecinfo"
SRCREV = "8768e39d3c8e74e583eca3897cc6de53a99c3dde"
@@ -34,6 +35,8 @@ S = "${WORKDIR}/git"
EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}"
+EXTRANATIVEPATH += "chrpath-native"
+
do_configure_append() {
# Find native tools
sed -i 's:${STAGING_BINDIR}.*/qdoc:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qdoc:g' ${B}/Makefile
@@ -52,6 +55,11 @@ do_install() {
install -m 0644 ${WORKDIR}/qtcreator.desktop.in ${D}${datadir}/applications/qtcreator.desktop
sed -i 's:@QT5_QMAKE@:${OE_QMAKE_PATH_QT_BINS}:g' ${D}${datadir}/applications/qtcreator.desktop
}
+do_install_append_toolchain-clang () {
+ # Remove RPATHs embedded in bins
+ chrpath --delete ${D}${libdir}/qtcreator/plugins/libClang*
+ chrpath --delete ${D}${libexecdir}/qtcreator/clang*
+}
FILES_${PN} += " \
${datadir}/qtcreator \