aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qt5-ptest.inc
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-09-21 12:49:50 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-09-25 12:14:50 +0300
commit6269d8a5bc402e6dafd8ee8499481d29792d1c4a (patch)
tree604131cc4f8a02426006aa728178540d9e76f303 /recipes-qt/qt5/qt5-ptest.inc
parent65172464082a07301fd46a8bc34d78860d2bc5ef (diff)
parent268429962056a12e0e899612dafb433c257af5cf (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.9
* qtyocto/upstream/master: qtwebengine: add patch for long paths qtwebengine: update 0004-Force-host-toolchain-configuration.patch qtwebengine: fix build with glibc-2.26 qt: upgrade to latest revision in 5.9 branch qt: refresh remaining patches and add links to meta-qt5 repos qtwebengine: add a fix for building demobrowser without printing support Upgrade to Qt 5.9.0 qtbase, qtgraphicaleffect, qtmultimedia, qtscript, qtlocation, qtwayland: disable gold to work around binutils bug qtwebengine: disable SECURITY_STRINGFORMAT to fix the build meta-toolchain-qt5: don't rely on COREBASE/LICENSE qtbase: fix Krogoth build regression from efa8aaf qt3d: refresh patches qtwebengine: refresh patches qtbase: refresh the patches gstreamer1.0-plugins-bad: add qt5 packageconfig qtbase: remove qtbase-native from DEPENDS qt3d: Fix build with clang qtwebkit: Backport a patch to fix build with icu-59 quazip: update to 0.7.3 and add missing metadata qtbase: Use sched_yield instead of pthread_yield qtbase: Fix ptests with clang qt5-ptest: fix build with yocto < 2.3 (pyro) qtbase: add ptest qwt-qt5.inc: fix QA warning qt5-git.inc: set CVE_PRODUCT to qt python-pyqt5: include QtWidgets module qt5-creator: Link with libexecinfo on musl qtvirtualkeyboard: Include sys/time.h qtwebengine: Fix build on musl qt5-creator: Fix build with NO_ACCESSIBILITY maliit-framework-qt5: Always have optimize flags qtbase-native: Fix qdbuscpp2xml segfault qt5-ptest.inc: append do_populate_sysroot only for target qtwebengine: fix build with gcc7 qwt-qt5: Fix rpath issues qtquickcontrols2: fix compilation of examples/texteditor qtquick1: add ptest qtdeclarative: add ptest qtxmlpatterns: add ptest qt5: add qt5-ptest.inc QtSystems module not updated as newer version fails to build with Yocto. Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtenginio_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick1_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch recipes-qt/qt5/qtwebengine/0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch recipes-qt/qt5/qtwebengine/0003-Include-dependency-to-QCoreApplication-translate.patch recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit-examples_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb Task-number: QTBUG-62635 Change-Id: I32dbc0b9c26916d57865a08ec6d55cd175c28fd0
Diffstat (limited to 'recipes-qt/qt5/qt5-ptest.inc')
-rw-r--r--recipes-qt/qt5/qt5-ptest.inc62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-ptest.inc b/recipes-qt/qt5/qt5-ptest.inc
new file mode 100644
index 00000000..4844878a
--- /dev/null
+++ b/recipes-qt/qt5/qt5-ptest.inc
@@ -0,0 +1,62 @@
+SRC_URI += "file://run-ptest"
+
+inherit ptest
+
+addtask do_populate_sysroot after do_install before do_compile_ptest_base
+deltask do_compile_ptest_base
+addtask do_compile_ptest_base after do_populate_sysroot before do_install_ptest
+addtask do_install_ptest after do_compile_ptest_base before do_package
+
+do_compile_ptest() {
+ cd ${S}/tests
+ qmake -o Makefile tests.pro
+ oe_runmake
+}
+
+do_populate_sysroot_append_class-target() {
+ workdir = d.getVar('WORKDIR', True)
+ srcdir = workdir + '/sysroot-destdir/usr/'
+ destdir = workdir + '/recipe-sysroot/usr/'
+
+ def copyFiles(sourceDir, targetDir, filelist):
+ for file in os.listdir(sourceDir):
+ sourceFile = os.path.join(sourceDir, file)
+ targetFile = os.path.join(targetDir, file)
+ filelist.append(targetFile) #record the file list
+ if os.path.isfile(sourceFile):
+ if not os.path.exists(targetDir):
+ os.makedirs(targetDir)
+ if not os.path.exists(targetFile) or(os.path.exists(targetFile) and (os.path.getsize(targetFile) != os.path.getsize(sourceFile))):
+ open(targetFile, "wb").write(open(sourceFile, "rb").read())
+ if os.path.isdir(sourceFile):
+ First_Directory = False
+ copyFiles(sourceFile, targetFile, filelist)
+
+ if os.path.exists(destdir):
+ Tmpfilelist = []
+ copyFiles(srcdir, destdir, Tmpfilelist)
+
+ fp=open(workdir + '/filelist', 'w')
+ for i in Tmpfilelist:
+ fp.write(i)
+ fp.write("\n")
+ fp.close()
+}
+
+fakeroot do_install_ptest() {
+ mkdir -p ${D}${PTEST_PATH}
+ t=${D}${PTEST_PATH}
+ for var in ` find ${S}/tests/auto/ -name tst_*`; do
+ if [ -z ` echo ${var##*/} | grep '\.'` ]; then
+ echo ${var##*/} >> ${t}/tst_list
+ install -m 0644 ${var} ${t}
+ fi
+ done
+ for file in `cat ${WORKDIR}/filelist`; do
+ if [ -f $file ]; then
+ rm -f $file
+ fi
+ done
+ rm -f ${WORKDIR}/filelist
+}
+