aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qt5.inc
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-03 17:12:39 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-08 14:19:10 +0100
commit909858baf064216a3b221edb59b40cc93d536a44 (patch)
tree98c17fe59d2fe43d1200d8e590bcd793dc893f4c /recipes-qt/qt5/qt5.inc
parent8e70eeb90910b46057fd29a16858de93d42717d5 (diff)
qt5: use common PACKAGECONFIG to build examples
Each Qt module's examples can now be enabled with PACKAGECONFIG. Replace the webkit patch with a PACKAGECONFIG option and follow common practice by not building QtWayland examples by default, those can be enabled in a .bbappend with PACKAGECONFIG += "examples" Enabling PACKAGECONFIG[examples] in qtbase, will still cause every Qt module to build their examples. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qt5.inc')
-rw-r--r--recipes-qt/qt5/qt5.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index ce9d976c..70e4b308 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -5,6 +5,9 @@ inherit qmake5
PACKAGECONFIG_OPENSSL ?= "openssl"
+PACKAGECONFIG[examples] = ""
+EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'examples', 'QT_BUILD_PARTS+=examples', '', d)}"
+
# we don't want conflicts with qt4
OE_QMAKE_PATH_HEADERS = "${OE_QMAKE_PATH_QT_HEADERS}"
OE_QMAKE_PATH_ARCHDATA = "${OE_QMAKE_PATH_QT_ARCHDATA}"