aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase-native_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-08-09 12:37:03 +0000
committerMartin 'JaMa' Jansa <Martin.Jansa@gmail.com>2018-08-14 13:49:18 +0200
commit539e4f09f749f024d6e157a49559e5ad7f51470a (patch)
treec26a323be297bccc50cc21314973ebbfd3661c3e /recipes-qt/qt5/qtbase-native_git.bb
parentc2e4ec603be96cf2ede2557e459c39d25db25937 (diff)
qtbase: fix build with glibc-2.28
Fixes: qtbase/5.11.1+gitAUTOINC+74305ba470-r0/git/src/corelib/io/qfilesystemengine_unix.cpp:94: qtbase/5.11.1+gitAUTOINC+74305ba470-r0/recipe-sysroot/usr/include/linux/stat.h:56:8: error: redefinition of 'struct statx_timestamp' struct statx_timestamp { ^~~~~~~~~~~~~~~ qtbase/5.11.1+gitAUTOINC+74305ba470-r0/recipe-sysroot/usr/include/bits/statx.h:25:8: note: previous definition of 'struct statx_timestamp' struct statx_timestamp ^~~~~~~~~~~~~~~ You might encounter another error: qtbase/5.11.1+gitAUTOINC+74305ba470-r0/git/src/corelib/io/qfilesystemengine_unix.cpp:109:12: error: 'int renameat2(int, const char*, int, const char*, unsigned int)' was declared 'extern' and later 'static' [-fpermissive] static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newpath, unsigned flags) ^~~~~~~~~ qtbase/5.11.1+gitAUTOINC+74305ba470-r0/recipe-sysroot/usr/include/stdio.h:164:12: note: previous declaration of 'int renameat2(int, const char*, int, const char*, unsigned int)' extern int renameat2 (int __oldfd, const char *__old, int __newfd, ^~~~~~~~~ In that case enable renameat2 in your PACKAGECONFIG. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase-native_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 819f4473..bffebdd1 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -19,7 +19,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.6
+# 5.11.meta-qt5-shared.7
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -34,18 +34,19 @@ SRC_URI += "\
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
+ file://0014-Fix-qmake-build-with-glibc-2.28.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.10-native
-# 5.11.meta-qt5-native.6
+# 5.11.meta-qt5-native.7
SRC_URI += " \
- file://0014-Always-build-uic-and-qvkgen.patch \
+ file://0015-Always-build-uic-and-qvkgen.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0015-Bootstrap-without-linkat-feature.patch \
+ file://0016-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"