aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-02-15 13:15:26 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-03-01 13:05:23 +0200
commita96836aedf30d2e26fbcafc13b1313d1325a0730 (patch)
treed525675103a4ddc88c25c2303b509f71bd447f32 /recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
parente721e84659869e4a04838d95d7cdbab9d48f5c3d (diff)
parentdb881bb4917628ad3eb1fa7c4f27915cf2ae60f4 (diff)
Merge remote-tracking branch 'qtyocto/upstream/rocko' into 5.9
* qtyocto/upstream/rocko: qwt-qt5: rewrite completely qt5: upgrade to 5.9.4 qt: refresh remaining patches and tags in meta-qt5 repos qtwebengine: explicitly depend on bison-native qtlocation: correct PACKAGECONFIG for mapboxgl gstreamer1.0-plugins-bad: add expansion parameter Bump to Qt 5.9.3 Conflicts: recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch recipes-qt/qt5/qtwayland_git.bb Change-Id: I1a9a35640f301f60d8363d4c3a6bb226ea40c2d1
Diffstat (limited to 'recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
new file mode 100644
index 00000000..09a7002f
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -0,0 +1,32 @@
+From cd179b5af4c479fa6deb6c8eace75a04848d7498 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Sep 2017 09:44:48 -0700
+Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
+
+This helps to make sure that QT_SOCKLEN_T is defined to be 'int'
+only when its glibc < 2 and not for other libcswhich may define
+it as per standards but are not glibc, e.g. musl
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/linux-clang/qplatformdefs.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mkspecs/linux-clang/qplatformdefs.h b/mkspecs/linux-clang/qplatformdefs.h
+index d29225f..a0cdb57 100644
+--- a/mkspecs/linux-clang/qplatformdefs.h
++++ b/mkspecs/linux-clang/qplatformdefs.h
+@@ -84,10 +84,10 @@
+
+ #undef QT_SOCKLEN_T
+
+-#if defined(__GLIBC__) && (__GLIBC__ >= 2)
+-#define QT_SOCKLEN_T socklen_t
+-#else
++#if defined(__GLIBC__) && (__GLIBC__ < 2)
+ #define QT_SOCKLEN_T int
++#else
++#define QT_SOCKLEN_T socklen_t
+ #endif
+
+ #if defined(_XOPEN_SOURCE) && (_XOPEN_SOURCE >= 500)