aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-04-17 23:32:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-04-18 23:04:41 +0000
commite2707a016c3475c167a421c9c73d88f81cc61bd1 (patch)
treee4bae2a878e4c97496dcd536af717f093c9579f2 /recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
parent07784245c1822766d54405d835ac2dc08652df1a (diff)
qt5: upgrade to 5.12.3
* be aware that in 3 qt* project the v5.12.3 tag wasn't created yet: qtknx_git.bb:# v5.12.3 tag wasn't created yet qtmqtt_git.bb:# v5.12.3 tag wasn't created yet qtopcua_git.bb:# v5.12.3 tag wasn't created yet * and qttools, qt3d, qtremoteobjects v5.12.3 tag isn't in 5.12 branch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
index 1f990f24..0a641bb2 100644
--- a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
+++ b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -1,4 +1,4 @@
-From 21bcae84788d1b14a754bc56a1adc43abf888e84 Mon Sep 17 00:00:00 2001
+From f5c88622ac10601e48a14f31d9299692a9ac62e2 Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 27 Oct 2018 12:29:31 +0000
Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
@@ -19,7 +19,7 @@ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
1 file changed, 8 insertions(+), 14 deletions(-)
diff --git a/src/gui/Qt5GuiConfigExtras.cmake.in b/src/gui/Qt5GuiConfigExtras.cmake.in
-index 07869efd7d..671aa82167 100644
+index 84dbbfebd4..ad6956d814 100644
--- a/src/gui/Qt5GuiConfigExtras.cmake.in
+++ b/src/gui/Qt5GuiConfigExtras.cmake.in
@@ -75,21 +75,15 @@ unset(_qt5gui_OPENGL_INCLUDE_DIR CACHE)
@@ -48,9 +48,9 @@ index 07869efd7d..671aa82167 100644
-!!ENDIF
+
foreach(_lib ${Libs})
- string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
- if (NOT TARGET Qt5::Gui_${_cmake_lib_name} AND NOT _Qt5Gui_${_cmake_lib_name}_LIBRARY_DONE)
-@@ -158,11 +152,11 @@ endmacro()
+ if (IS_ABSOLUTE ${_lib})
+ get_filename_component(_libFile ${_lib} NAME_WE)
+@@ -171,11 +165,11 @@ endmacro()
!!IF !isEmpty(CMAKE_EGL_LIBS)