aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-06-09 09:34:09 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-20 19:30:05 +0200
commit969f1f80bf255498abbec6886d443670c20a79c8 (patch)
tree45a65f19da61868c2fe71669fb4b7d29b374edac /recipes-qt/qt5/qtbase
parent648f7b0a2eb202d4378ce50ae566b6ca450dd010 (diff)
Upgrade to Qt 5.9.0
* adapt QtWebEngine recipe to use GN instead of GYP * add QtRemoteObjects and QtWebView as a new Qt modules * update available QtBase configure arguments * remove obsolete patches * patch all .pc files to remove build paths * include generated QML cache files in packages * the patch "configure paths for target qmake properly" could not be applied anymore and support must be done differently * QtWebEngine now requires gcc-multilib to be installed on the host system, because the host tools are built to the same bitness as the target (arm -> x86, aarch64 -> x86-64) * refresh the patches to match with b5.9* branches on: https://github.com/meta-qt5/qtbase https://github.com/meta-qt5/qtwebengine and 56-based branch on https://github.com/meta-qt5/qtwebengine-chromium Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase')
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch14
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch (renamed from recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch (renamed from recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch34
-rw-r--r--recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch106
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch (renamed from recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch33
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch (renamed from recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch)4
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch (renamed from recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch (renamed from recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch)10
-rw-r--r--recipes-qt/qt5/qtbase/0009-Always-build-uic.patch (renamed from recipes-qt/qt5/qtbase/0011-Always-build-uic.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch28
-rw-r--r--recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch75
13 files changed, 61 insertions, 269 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 3f373c76..28c26603 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 805b338154ed0262a7b8bf5c582ff5b193a55492 Mon Sep 17 00:00:00 2001
+From e13425e6f1e784b0b016cf68a54dfbae32995b86 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -30,10 +30,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index bc18e614d2..579a96d787 100755
+index 73679de621..5a0eebce50 100755
--- a/configure
+++ b/configure
-@@ -1614,7 +1614,7 @@ fi
+@@ -709,7 +709,7 @@ fi
# is where the resulting variable is written to
setBootstrapVariable()
{
@@ -43,10 +43,10 @@ index bc18e614d2..579a96d787 100755
# build qmake
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index 4ca7c6ba07..5b5ac13f1d 100644
+index 934a18a924..0f5b1b6333 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
-@@ -44,14 +44,14 @@ defineTest(qtCompileTest) {
+@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
}
# Clean up after previous run
@@ -64,10 +64,10 @@ index 4ca7c6ba07..5b5ac13f1d 100644
msg = "test $$1 succeeded"
write_file($$QMAKE_CONFIG_LOG, msg, append)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 999cd18154..2ac91ba519 100644
+index c00fdb73f8..0cf4de7b49 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
-@@ -67,7 +67,7 @@ defineTest(qtHaveModule) {
+@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
defineTest(qtPrepareTool) {
cmd = $$eval(QT_TOOL.$${2}.binary)
isEmpty(cmd) {
diff --git a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index 9f1a2b2c..5ee6e049 100644
--- a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,9 +1,9 @@
-From 67977e16e5d0aecd931d8e4355c12cc907df592f Mon Sep 17 00:00:00 2001
+From 5ed152f8caa7ef00fb20d19a06ab5f7887e9aba6 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
-Subject: [PATCH] Add -external-hostbindir option
+Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
-* cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS to determine path to host binaries
+... to determine path to host binaries
Upstream-Status: Inappropriate [OE specific]
diff --git a/recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index f9859620..7ff1ff71 100644
--- a/recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 18e2f4368f22bf5ac8b2a36c30a7ad39ed97bf49 Mon Sep 17 00:00:00 2001
+From 77fab782e8a199f9ede83bc97cbce21a544961c2 Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
@@ -19,10 +19,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
-index 27fe10a79e..29ffcda203 100644
+index b4ba0b5b2e..11d4c00f39 100644
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
-@@ -164,7 +164,10 @@ void QLibrarySettings::load()
+@@ -172,7 +172,10 @@ void QLibrarySettings::load()
QSettings *QLibraryInfoPrivate::findConfiguration()
{
#ifdef QT_BUILD_QMAKE
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
new file mode 100644
index 00000000..5ab6a7b1
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -0,0 +1,34 @@
+From 4848804312f0045b53c85db113ac9e42fe1b7360 Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Tue, 25 Aug 2015 10:05:15 -0400
+Subject: [PATCH] configure: bump path length from 256 to 512 characters
+
+Increase the path length that gets hardcoded into generated config.cpp file
+from 256 to 512 characters, as nativesdk path can be quite long.
+
+Also update length of EXT_PREFIX and HOST_PREFIX now.
+
+Change-Id: If98dd57160efe9c98c36148cdf872f50b3d38118
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ configure.pri | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.pri b/configure.pri
+index be1b166080..52f03bf3f2 100644
+--- a/configure.pri
++++ b/configure.pri
+@@ -796,10 +796,10 @@ defineTest(qtConfOutput_preparePaths) {
+ "static const char qt_configure_installation [12+11] = \"qt_instdate=2012-12-20\";" \
+ "" \
+ "/* Installation Info */" \
+- "static const char qt_configure_prefix_path_str [12+256] = \"qt_prfxpath=$$config.input.prefix\";" \
++ "static const char qt_configure_prefix_path_str [12+512] = \"qt_prfxpath=$$config.input.prefix\";" \
+ "$${LITERAL_HASH}ifdef QT_BUILD_QMAKE" \
+- "static const char qt_configure_ext_prefix_path_str [12+256] = \"qt_epfxpath=$$config.input.extprefix\";" \
+- "static const char qt_configure_host_prefix_path_str [12+256] = \"qt_hpfxpath=$$config.input.hostprefix\";" \
++ "static const char qt_configure_ext_prefix_path_str [12+512] = \"qt_epfxpath=$$config.input.extprefix\";" \
++ "static const char qt_configure_host_prefix_path_str [12+512] = \"qt_hpfxpath=$$config.input.hostprefix\";" \
+ "$${LITERAL_HASH}endif" \
+ "" \
+ "static const short qt_configure_str_offsets[] = {" \
diff --git a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch b/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
deleted file mode 100644
index aa97b56f..00000000
--- a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-From fe9cfbde28c651d00b8f5fda7dc85a97af0c50a1 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Sat, 27 Apr 2013 23:15:37 +0200
-Subject: [PATCH] qt_module: Fix pkgconfig and libtool replacements
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-* in situation like this:
- QT_SYSROOT:/OE/oe-core/tmp-eglibc/sysroots/qemuarm
- QT_INSTALL_LIBS:/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib
- QT_INSTALL_LIBS/raw:/usr/lib
- QT_INSTALL_LIBS/get:/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib
-
- I don't want the replacement like this:
- sed
- -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/include,/usr/include/qt5,g"
- -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib,/usr/lib,g"
- "../../lib/pkgconfig/Qt5Core.pc"
- >"/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/image/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib/pkgconfig/Qt5Core.pc"
- because that way I'll end with -L/usr/lib in .pc file which is
- cross-compile unfriendly, keeping ${libdir}/${includedir} works better
- in my case
-
-* qt_module: Fix paths in .prl files
-* qmake does not prefix them with QT_SYSROOT when using them
- so e.g. when building qtdeclarative we get -L/usr/lib to LINKAGE
- variable, which is unsafe for cross-compilation
-* writting QT_SYSROOT in .prl files is dangerous for sstate when
- builds are in different directories, so we need
- SSTATE_SCAN_FILES += "*.pri *.prl"
- to make them relocateble
-
-* fix paths in packageconfig files
- This reverts parts of:
-
- enable path replacement in installed prl files on all platforms
-
- Task-number: QTBUG-33794
- Change-Id: Id0d38715673b8a1c0c034e9c15783eb255c4315b
- Reviewed-by: Joerg Bornemann <joerg.bornemann@digia.com>
-
-* to debug this, rebuild qtbase and read build/src/corelib/Makefile
-* this is example of broken install_target rule (added line feeds):
- -$(SED) -e s,/OE/5.3.1-r0/build/lib,/usr/lib,g
- -e 's,/OE/5.3.1-r0/build/include,$$\{includedir},g'
- -e 's,/OE/5.3.1-r0/build/lib,$$\{libdir},g'
- "../../lib/pkgconfig/Qt5Core.pc"
- >"$(INSTALL_ROOT)/usr/lib/pkgconfig/Qt5Core.pc"
- change .prf files, create copy of WORKDIR, re-excecute only
- do_configure task and compare generated Makefile, repeat until
- replace in generated Makefile works ok, then refresh patch and
- try complete rebuild for qtbase
-* if everything is ok, then try:
- image $ grep -R "\-L/usr" .
- image $ grep -R "\-I/usr" .
- and it should return only few cases of
- qmake.conf:QMAKE_LFLAGS_THREAD = -L/usr/lib/threads
- for aix* platformas
-
-Change-Id: Ie1c94b15f2a4e736b65b4d0924d99eb2a7d92a6c
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-Signed-off-by: Jonathan Liu <net147@gmail.com>
----
- mkspecs/features/qt.prf | 13 +++++++++++++
- mkspecs/features/qt_common.prf | 2 +-
- 2 files changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
-index 98f794c485..bd8b7b52e4 100644
---- a/mkspecs/features/qt.prf
-+++ b/mkspecs/features/qt.prf
-@@ -315,6 +315,19 @@ contains(TEMPLATE, .*app) {
- QTPLUGIN = $$manualplugs $$autoplugs
- }
-
-+contains(TEMPLATE, .*lib) {
-+ pkgconfig_prefix_replace.match = "prefix=$$[QT_SYSROOT]"
-+ pkgconfig_prefix_replace.replace = "prefix="
-+ pkgconfig_prefix_replace.CONFIG = path
-+ QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_prefix_replace
-+
-+ # drop -L/usr/lib in .prl files
-+ prl_replace.match = "-L\$${libdir}"
-+ prl_replace.replace = ""
-+ prl_replace.CONFIG = path
-+ QMAKE_PRL_INSTALL_REPLACE += prl_replace
-+}
-+
- QT_PLUGIN_VERIFY = DEPLOYMENT_PLUGIN
- qtConfig(static) {
- QT_PLUGIN_VERIFY += QTPLUGIN
-diff --git a/mkspecs/features/qt_common.prf b/mkspecs/features/qt_common.prf
-index d30983f62b..6da07e032c 100644
---- a/mkspecs/features/qt_common.prf
-+++ b/mkspecs/features/qt_common.prf
-@@ -37,7 +37,7 @@ contains(TEMPLATE, .*lib) {
- lib_replace.replace =
- } else {
- lib_replace.match = $$rplbase/lib
-- lib_replace.replace = $$qqt_libdir
-+ lib_replace.replace = "\$$\\{libdir}"
- }
- lib_replace.CONFIG = path
- QMAKE_PRL_INSTALL_REPLACE += lib_replace
diff --git a/recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index c2b44381..8538901f 100644
--- a/recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From 8acdd69a4083080f4dd40001eee30209ec5de0b2 Mon Sep 17 00:00:00 2001
+From 6ecb404346525a92f4c8926aa285662f3f5010b3 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
@@ -10,10 +10,10 @@ Change-Id: Ib884fe33cac74439f9592b145937f6b75ced8447
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf
-index eaaa161270..fa3addae11 100644
+index 966c43108c..32f0dd0041 100644
--- a/mkspecs/features/qt_configure.prf
+++ b/mkspecs/features/qt_configure.prf
-@@ -1035,7 +1035,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
+@@ -1180,7 +1180,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
error("Expression '$$1' is accessing field '$$var' of non-local feature $${feature}.")
return($$result)
}
diff --git a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
deleted file mode 100644
index 0c0d2c73..00000000
--- a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From be9179d2cbb9009794940092d30dac7800708964 Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Tue, 25 Aug 2015 10:05:15 -0400
-Subject: [PATCH] configure: bump path length from 256 to 512 characters
-
-Increase the path length that gets hardcoded into generated config.cpp file
-from 256 to 512 characters, as nativesdk path can be quite long.
-
-Also update length of EXT_PREFIX and HOST_PREFIX now.
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- configure | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/configure b/configure
-index 579a96d787..5af98cd77e 100755
---- a/configure
-+++ b/configure
-@@ -1551,10 +1551,10 @@ cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
- static const char qt_configure_installation [12+11] = "qt_instdate=2012-12-20";
-
- /* Installation Info */
--static const char qt_configure_prefix_path_str [256 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
-+static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
- #ifdef QT_BUILD_QMAKE
--static const char qt_configure_ext_prefix_path_str [256 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
--static const char qt_configure_host_prefix_path_str [256 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
-+static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
-+static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
- #endif
-
- static const short qt_configure_str_offsets[] = {
diff --git a/recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index b70b0d35..253815bd 100644
--- a/recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From 5316b420dc408d3a47daa3ba854a7883c911f6b9 Mon Sep 17 00:00:00 2001
+From 3730ac03a1473a0e1fdfe1537b73818ab99961e9 Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
@@ -30,7 +30,7 @@ Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
2 files changed, 10 insertions(+)
diff --git a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
-index d2358cae4b..feb73c02a5 100644
+index 4f342d67d7..202b723882 100644
--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
@@ -9,6 +9,11 @@ if (CMAKE_VERSION VERSION_LESS 3.0.0)
diff --git a/recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index c992586a..68e4b201 100644
--- a/recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From 2755a80114433e75f08fbb0df0fee9f7526172aa Mon Sep 17 00:00:00 2001
+From 2fa6b447302abbaf1fd710e94b92692a300baaaf Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 5c625e08..678de529 100644
--- a/recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From bbe822066913c0908b6366009517c19e828e1458 Mon Sep 17 00:00:00 2001
+From 41d7028d2239a98a76cc91939edb2cb728019d08 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
-index 7d9f56ef38..bc115ef61d 100644
+index b6106e8c9e..6d6ea0b739 100644
--- a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
+++ b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
@@ -34,7 +34,7 @@
@@ -36,10 +36,10 @@ index 7d9f56ef38..bc115ef61d 100644
QMetaType info(tp);
if (!info.isValid()) {
diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-index fe1057bdde..e23e97b259 100644
+index 7340817ade..f34162a105 100644
--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-@@ -75,6 +75,7 @@
+@@ -77,6 +77,7 @@
#include <stdlib.h>
#include <sys/stat.h>
#include <unistd.h>
@@ -47,7 +47,7 @@ index fe1057bdde..e23e97b259 100644
#endif
#include "private/qhostinfo_p.h"
-@@ -2129,8 +2130,8 @@ public slots:
+@@ -2131,8 +2132,8 @@ public slots:
#if defined(Q_OS_MAC)
pthread_yield_np();
diff --git a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
index 244cc0bc..118a4f29 100644
--- a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
@@ -1,4 +1,4 @@
-From 7c42f9b42c34d75f6c8e21e55af9b0e58f5743cc Mon Sep 17 00:00:00 2001
+From 294e4c718407e66631ce36c37258217c9adb3f83 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic
@@ -14,10 +14,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/src.pro b/src/src.pro
-index 90d7e2b76c..4ca6b0bd01 100644
+index 43fc06f2e5..1e9d4dcc0d 100644
--- a/src/src.pro
+++ b/src/src.pro
-@@ -188,7 +188,7 @@ qtConfig(gui) {
+@@ -203,7 +203,7 @@ qtConfig(gui) {
}
}
}
diff --git a/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch b/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch
deleted file mode 100644
index 609cd846..00000000
--- a/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7bab0171601bc769403be62d145164137f1b7b66 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 25 Jul 2017 19:40:52 -0700
-Subject: [PATCH] tst_qstring: Disable Wformat-security with clang as well
-
-Currently, its only disabled for gcc, but we need to disable
-it with clang as well in order to compile it successfully with
-clang
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/auto/corelib/tools/qstring/tst_qstring.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/auto/corelib/tools/qstring/tst_qstring.cpp b/tests/auto/corelib/tools/qstring/tst_qstring.cpp
-index a0a872710c..20a9a9f9db 100644
---- a/tests/auto/corelib/tools/qstring/tst_qstring.cpp
-+++ b/tests/auto/corelib/tools/qstring/tst_qstring.cpp
-@@ -1066,6 +1066,9 @@ void tst_QString::acc_01()
-
- QT_WARNING_PUSH
- QT_WARNING_DISABLE_GCC("-Wformat-security")
-+#ifdef __clang__
-+QT_WARNING_DISABLE_CLANG("-Wformat-security")
-+#endif
-
- void tst_QString::isNull()
- {
diff --git a/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch b/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
deleted file mode 100644
index c527c131..00000000
--- a/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From b8e94df3d49be69659e8dfb0809c614f73c21706 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Fri, 13 Nov 2015 12:36:11 +0100
-Subject: [PATCH] configure paths for target qmake properly
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-to use this patch in all qtbase/qtbase-native(sdk) changes ore made
-conditionally based on QT_CROSS_COMPILE
-
-Upstream-Status: Inappropriate [OE specific]
-
-Change-Id: I2b2f00c496216e98fbe14801f9e840ef5333c4b6
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- configure | 23 +++++++++++++++++++----
- 1 file changed, 19 insertions(+), 4 deletions(-)
-
-diff --git a/configure b/configure
-index 5af98cd77e..34dedafe91 100755
---- a/configure
-+++ b/configure
-@@ -1500,8 +1500,13 @@ if [ -z "$QT_REL_HOST_DATA" ]; then
- fi
- fi
-
--shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
--shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
-+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
-+ shortxspec=linux-g++
-+ shortspec=linux-g++
-+else
-+ shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
-+ shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
-+fi
-
- QT_CONFIGURE_STR_OFF=0
-
-@@ -1534,7 +1539,11 @@ QT_CONFIGURE_STRS_ALL=$QT_CONFIGURE_STRS
-
- QT_CONFIGURE_STR_OFFSETS=
- QT_CONFIGURE_STRS=
--addConfStr "$CFG_SYSROOT"
-+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
-+ addConfStr ""
-+else
-+ addConfStr "$CFG_SYSROOT"
-+fi
- addConfStr "$QT_REL_HOST_BINS"
- addConfStr "$QT_REL_HOST_LIBS"
- addConfStr "$QT_REL_HOST_DATA"
-@@ -1546,6 +1555,12 @@ addConfStr "$shortspec"
- #-------------------------------------------------------------------------------
- [ -d "$outpath/src/corelib/global" ] || mkdir -p "$outpath/src/corelib/global"
-
-+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
-+ QT_TARGET_PREFIX=$QT_EXT_PREFIX
-+else
-+ QT_TARGET_PREFIX=$QT_HOST_PREFIX
-+fi
-+
- cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
- /* Installation date */
- static const char qt_configure_installation [12+11] = "qt_instdate=2012-12-20";
-@@ -1554,7 +1569,7 @@ static const char qt_configure_installation [12+11] = "qt_instdate=2
- static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
- #ifdef QT_BUILD_QMAKE
- static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
--static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
-+static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_TARGET_PREFIX";
- #endif
-
- static const short qt_configure_str_offsets[] = {