aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-05-23 10:28:00 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-05-23 10:34:18 +0300
commitbaf9b8e6918c76d7f58d557d9a102b5b5d1727c0 (patch)
tree9cbaaa54acd3ce1d0cc52b7a9045240723f8b9da /recipes-qt/qt5/qtbase_git.bb
parent89ac66bf3969b48eb771ef4c06a0b8df00fd178a (diff)
parent60e61ea26a0f221fdb8c992990686c9f449f27c5 (diff)
Merge remote-tracking branch 'qtyocto/upstream/warrior' into 5.12
* qtocto/upstream/warrior: 60e61ea qt3d-runtime: update to v2.3 cad5f8c qtbase: add no-opengl to PACKAGECONFIG_GL when opengl isn't in DISTRO_FEATURES 44aab3a qtbase: add accessibility from PACKAGECONFIG_KDE to PACKAGECONFIG_DEFAULT 000e298 qtbase: add libxext dependency for xcb PACKAGECONFIG ba08444 python-pyqt5: Update to version 5.12.1. 6a1a387 python-pyqt: Fix annoying problems. c7e0ba5 qtwebengine: arm: use OE specified -mcpu option 9c62c01 qtbase-tools: Fix error during pkg_postinst f4531ec qtwebengine: restore the fix for build with clang/libc++ on aarch64/arm Conflicts: recipes-qt/qt5/qtbase_git.bb Change-Id: I853b6669bd4e42224b278587c412032903ba5555
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5df0043e..00e994db 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -38,10 +38,10 @@ SRC_URI += "\
RDEPENDS_${PN}-tools += "perl"
# separate some parts of PACKAGECONFIG which are often changed
-PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
+PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', 'no-opengl', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xcb-xinput glib xkb xkbcommon', '', d)}"
-PACKAGECONFIG_KDE ?= "${@bb.utils.contains('DISTRO_FEATURES', 'kde', 'sm cups fontconfig kms gbm libinput sql-sqlite accessibility openssl', '', d)}"
+PACKAGECONFIG_KDE ?= "${@bb.utils.contains('DISTRO_FEATURES', 'kde', 'sm cups fontconfig kms gbm libinput sql-sqlite openssl', '', d)}"
PACKAGECONFIG_FONTS ?= ""
PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib"
PACKAGECONFIG_DISTRO ?= ""
@@ -49,7 +49,7 @@ PACKAGECONFIG_DISTRO ?= ""
PACKAGECONFIG_RELEASE ?= "release"
# This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency
# PACKAGECONFIG_OPENSSL ?= "openssl"
-PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \
+PACKAGECONFIG_DEFAULT ?= "accessibility dbus udev evdev widgets tools libs freetype tests \
${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)} \
"
@@ -103,7 +103,7 @@ PACKAGECONFIG[no-opengl] = "-no-opengl"
PACKAGECONFIG[tslib] = "-tslib,-no-tslib,tslib"
PACKAGECONFIG[cups] = "-cups,-no-cups,cups"
PACKAGECONFIG[dbus] = "-dbus,-no-dbus,dbus"
-PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -system-xcb,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil"
+PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -system-xcb,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil libxext"
PACKAGECONFIG[sql-ibase] = "-sql-ibase,-no-sql-ibase"
PACKAGECONFIG[sql-mysql] = "-sql-mysql -mysql_config ${STAGING_BINDIR_CROSS}/mysql_config,-no-sql-mysql,mysql5"
PACKAGECONFIG[sql-psql] = "-sql-psql,-no-sql-psql,postgresql"