aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-03-20 12:23:26 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-03-20 12:32:50 +0200
commitbd7a586d835d1dd0a5b201338e223fb94adc4380 (patch)
tree2ec50ae595f291ccc80f046f6824c7f03d7b1f2a /recipes-qt/qt5/qtbase_git.bb
parent26205f49f51b5727d75bf8f02a894e04bf7b7942 (diff)
parent0b0a608ddc55acf1f817aee03e65a06017239bed (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.12
* upstream/master: 0b0a608 qtbase: let user decide how to link openssl to Qt5 libraries 47d1132 qtbase: fix target mkspec adjustment 87f0462 qttools/cmake: use OE_QMAKE_PATH_EXTERNAL_HOST_BINS fe88b99 nativesdk-qtbase: use rpath for nativesdk Qt tools 92c34de qt5: cleanup mkspecs e117b58 qtbase: Fix test builds with clang/x86_64 6280bef qtscript: add fix for build with gcc 8.3 77ed8fb qtbase: Adjust target mkspec settings 75c7d00 qt5-creator: Do not ship two desktop files 6629131 packagegroup-qt5-toolchain-target: add qtbase-tools Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch recipes-qt/qt5/qtbase_git.bb Change-Id: Iaa69404f2d91bd492eea527548b7cf7c504b7bde
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb23
1 files changed, 22 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 943ab08e..836f57fa 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -89,6 +89,9 @@ PACKAGECONFIG ?= " \
${PACKAGECONFIG_SYSTEM} \
${PACKAGECONFIG_DISTRO} \
"
+# Choose whether to link to OpenSSL library at linking time or run time
+# Leave the variable empty to let the buildsystem decide, or specify -linked or -runtime
+OPENSSL_LINKING_MODE ??= ""
PACKAGECONFIG[static] = "-static,-shared"
PACKAGECONFIG[release] = "-release,-debug"
@@ -148,7 +151,7 @@ PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl"
PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
PACKAGECONFIG[icu] = "-icu,-no-icu,icu"
PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev"
-PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
+PACKAGECONFIG[openssl] = "-openssl${OPENSSL_LINKING_MODE},-no-openssl,openssl,libssl"
PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
@@ -263,4 +266,22 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
+TARGET_MKSPEC ?= "linux-g++"
+
+# use clean mkspecs on target
+pkg_postinst_${PN}-tools () {
+sed -i \
+ -e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
+ -e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
+ $D${bindir}/qt.conf
+}
+
+pkg_postinst_${PN}-mkspecs () {
+sed -i 's: cross_compile : :g' $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qconfig.pri
+sed -i \
+ -e 's: cross_compile : :g' \
+ -e 's:HOST_QT_TOOLS =.*::g' \
+ $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
+}
+
SRCREV = "856fb1ab44722f5165fb6b5dec0bd748006acd10"