aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorDan Ackers <dan.ackers@qt.io>2021-10-18 12:11:15 +0300
committerDan Ackers <dan.ackers@qt.io>2021-10-18 13:06:32 +0300
commitf29bed63aeb4833512489a8f54297a50fee6ae46 (patch)
treeabe9b66e4376afe0df0cde33fc41e8cbc8553fc9 /recipes-qt/qt5/qtbase_git.bb
parentbbad5a0a1981afd11489489ce668c60b41f39d25 (diff)
Merge remote-tracking branch 'warrior' into 5.12
Topics of changes that are brought in: *qtwebkit: Add patch to fix build with bison 3.7 *qtwebkit: Fix build with icu-65.1 *qtwebkit: fix build with icu >= 68 *qtwebengine: fix build with glibc-2.34 *qtwebengine: Fix build with ninja >= 1.10.0 -For now just skip version check *qtdeclarative: Ask for python3 explicitly *nativesdk-qtbase: inherit pkgconfig -some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly *qtwebkit: Inherit pkgconfig *qtgamepad: inherit pkgconfig *qtwayland: Inherit pkgconfig *qtwebengine: inherit pkgconfig *qtmultimedia: inherit pkgconfig *maliit-framework-qt5: inherit pkgconfig *qtbase: inherit pkgconfig *qt5-native.inc, nativesdk-qt5.inc, nativesdk-packagegroup-qt5-toolchain-host: reorder inherits to fix new QA check *cinematicexperience: don't use trailing slash in S *qtbase-native: disable vulkan support *qtbase: Add vulkan to PACKAGECONFIGs Conflicts: recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch recipes-qt/qt5/qtbase_git.bb Change-Id: Id4bce68abb2c2f813f16363fdec1e1d3d74bf58e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 80bfebc2..1be0f6c0 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.9
+# 5.12.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -33,11 +33,14 @@ SRC_URI += "\
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
+ file://0018-qfloat16-Include-limits-header.patch \
"
# for syncqt
RDEPENDS_${PN}-tools += "perl"
+inherit pkgconfig
+
# separate some parts of PACKAGECONFIG which are often changed
PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', 'no-opengl', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
@@ -136,6 +139,7 @@ PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
PACKAGECONFIG[journald] = "-journald,-no-journald,systemd"
# needs kernel 3.17+
PACKAGECONFIG[getentropy] = "-feature-getentropy,-no-feature-getentropy,"
+PACKAGECONFIG[vulkan] = "-vulkan,-no-vulkan,vulkan-headers"
QT_CONFIG_FLAGS_GOLD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '-use-gold-linker', '-no-use-gold-linker', d)}"
# workaround for gold bug:
@@ -276,4 +280,22 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
+TARGET_MKSPEC ?= "linux-g++"
+
+# use clean mkspecs on target
+pkg_postinst_${PN}-tools () {
+sed -i \
+ -e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
+ -e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
+ $D${OE_QMAKE_PATH_BINS}/qt.conf
+}
+
+pkg_postinst_${PN}-mkspecs () {
+sed -i 's: cross_compile : :g' $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qconfig.pri
+sed -i \
+ -e 's: cross_compile : :g' \
+ -e 's:HOST_QT_TOOLS =.*::g' \
+ $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
+}
+
SRCREV = "4341f6763b8a737ebc07bb78ead22bc05a1a515b"