aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-01-12 16:21:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:16:27 +0100
commit3bd297278dff1ae12d1241dc21e1e2643d7ccee2 (patch)
treed007cc574c4ce176bd054bc33f5ccd6710987f11 /recipes-qt/qt5/qtbase_git.bb
parent3e2058f2e735bbfd15723ce9de27ad8df78a5500 (diff)
qtbase: re-enable replacing host paths in qconfig.pri
Uncomment code that replaces host paths with qmake built-in properties in qconfig.pri. Modified to replace paths in all *.pri files in mkspecs directory and to also change paths without space in front of it. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 7ee5f562..8f519fa7 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -222,9 +222,9 @@ do_install_append() {
rm -rf ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/macx-ios-clang
# Replace host paths with qmake built-in properties
-# sed -i -e 's| ${STAGING_DIR_NATIVE}${prefix_native}| $$[QT_HOST_PREFIX]|g' \
-# -e 's| ${STAGING_DIR_HOST}| $$[QT_SYSROOT]|g' \
-# ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/qconfig.pri
+ sed -i -e 's|${STAGING_DIR_NATIVE}${prefix_native}|$$[QT_HOST_PREFIX]|g' \
+ -e 's|${STAGING_DIR_HOST}|$$[QT_SYSROOT]|g' \
+ ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/*.pri
}
PACKAGES =. " \