aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-03-19 09:14:51 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-03-19 10:57:46 +0200
commitb32b7990fa5047b9bf687d3a3ddff29b55c3d7d5 (patch)
treeea233454079644ae80564727a4af6b9c8e511003 /recipes-qt/qt5/qtbase_git.bb
parent13de43550479ca56f6e680369c32df8344524152 (diff)
parente60e849de1158c879bd2c150fe79b207cdac031a (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.11
* upstream/master: e60e849 qtpurchasing: upgrade to 5.10.1 14973ed qt5: Add recipe for qtpurchasing. 1d9fbb1 qt5: refresh patches from meta-qt5/qt* repos a5aadb7 qtbase: Replace -isystem with -I 6f9d4fd qtbase: add a config option to optimize for size 1ad923a packagegroup-qt5-toolchain-target: Add qtcharts and qtmqtt e41caf4 Upgrade to Qt 5.10.1 5250890 qt5: refactor ptest 3f2f3a0 qtbase: fix pcre PACKAGECONFIG Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmqtt_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtscxml_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb recipes-qt/qt5/qtx11extras_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Task-number: QTBUG-66307 Change-Id: Iccd55144b937f963bf4d6ea2d7c2ecc00adf9864
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 99f619ea..e25d0d68 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -17,7 +17,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.10-shared
-# 5.10.meta-qt5-shared.1
+# 5.10.meta-qt5-shared.2
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -30,6 +30,7 @@ SRC_URI += "\
file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
+ file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
"
# LGPL-3.0 is used only in src/plugins/platforms/android/extract.cpp
@@ -70,7 +71,9 @@ PACKAGECONFIG_DISTRO ?= ""
PACKAGECONFIG_RELEASE ?= "release"
# This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency
# PACKAGECONFIG_OPENSSL ?= "openssl"
-PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests"
+PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \
+ ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size', '', d)} \
+"
PACKAGECONFIG ?= " \
${PACKAGECONFIG_RELEASE} \
@@ -87,6 +90,7 @@ PACKAGECONFIG ?= " \
PACKAGECONFIG[release] = "-release,-debug"
PACKAGECONFIG[debug] = ""
PACKAGECONFIG[developer] = "-developer-build"
+PACKAGECONFIG[optimize-size] = "-optimize-size"
PACKAGECONFIG[sm] = "-sm,-no-sm"
PACKAGECONFIG[tests] = "-make tests,-nomake tests"
PACKAGECONFIG[examples] = "-make examples -compile-examples,-nomake examples"
@@ -106,7 +110,7 @@ PACKAGECONFIG[libpng] = "-system-libpng,-no-libpng,libpng"
PACKAGECONFIG[gif] = "-gif,-no-gif"
PACKAGECONFIG[ico] = "-ico,-no-ico"
PACKAGECONFIG[zlib] = "-system-zlib,-qt-zlib,zlib"
-PACKAGECONFIG[pcre] = "-system-pcre,-qt-pcre,pcre"
+PACKAGECONFIG[pcre] = "-system-pcre,-qt-pcre,pcre2"
PACKAGECONFIG[eglfs] = "-eglfs,-no-eglfs,drm"
PACKAGECONFIG[gl] = "-opengl desktop,,virtual/libgl"
PACKAGECONFIG[gles2] = "-opengl es2,,virtual/libgles2 virtual/egl"