aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-01-10 10:10:17 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-01-10 10:10:17 +0200
commitbc0625e7a03f9f04fdae3a89137812a216e977cd (patch)
tree4adb4e8357aea4922fd27e9758ea649deba73362 /recipes-qt/qt5/qtbase_git.bb
parenta22c728d16e449f3f573f4fd1324486753378592 (diff)
parent3cf0bbb8e1113376d5b5b26ecff362e180a180fd (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.10
* qtyocto/upstream/master: qtbase_git: install qt.conf for the target qtbase: mkspecs: add default toolchain options qt5: remove use of OE_QMAKE_WAYLAND_SCANNER gstreamer1.0-plugins-bad: add expansion parameter qtlocation: correct PACKAGECONFIG for mapboxgl qt5: use correct HostPrefix qwt-qt5: rewrite completely Fix missing OE_QMAKE_STRIP env variable Upgrade to Qt 5.10.0 qtwebengine: make test suite succeed Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb ecipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtscxml_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb recipes-qt/qt5/qtx11extras_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Task-number: QTBUG-65164 Change-Id: I3a54ce7f3f82dcce2d9d1a13585a41178bda358c
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb26
1 files changed, 23 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5bbbffeb..aa89280b 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -218,9 +218,29 @@ do_install_append() {
-e 's|${STAGING_DIR_HOST}|$$[QT_SYSROOT]|g' \
${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/*.pri
- # Fix up absolute paths in scripts
- grep -lr /usr/bin/perl ${D}${OE_QMAKE_PATH_QT_ARCHDATA}/ | \
- xargs -r sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,'
+ # Update the mkspecs to include the default OE toolchain config for the target
+ conf=${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/${XPLATFORM}/qmake.conf
+
+ # qmake already knows the sysroot, see above $$[QT_SYSROOT], so remove the hardcoded sysroot
+ OE_QMAKE_CC_NO_SYSROOT=$(echo ${OE_QMAKE_CC} | sed -e 's!--sysroot=[^ ]*!!g')
+ OE_QMAKE_CXX_NO_SYSROOT=$(echo ${OE_QMAKE_CXX} | sed -e 's!--sysroot=[^ ]*!!g')
+ OE_QMAKE_LINK_NO_SYSROOT=$(echo ${OE_QMAKE_LINK} | sed -e 's!--sysroot=[^ ]*!!g')
+
+ echo "" >> $conf
+ echo "# default compiler options which can be overwritten from the environment" >> $conf
+ echo "isEmpty(QMAKE_AR): QMAKE_AR = ${OE_QMAKE_AR} cqs" >> $conf
+ echo "isEmpty(QMAKE_CC): QMAKE_CC = $OE_QMAKE_CC_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_CFLAGS): QMAKE_CFLAGS = ${OE_QMAKE_CFLAGS}" >> $conf
+ echo "isEmpty(QMAKE_CXX): QMAKE_CXX = $OE_QMAKE_CXX_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_CXXFLAGS): QMAKE_CXXFLAGS = ${OE_QMAKE_CXXFLAGS}" >> $conf
+ echo "isEmpty(QMAKE_LINK): QMAKE_LINK = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_LINK_SHLIB): QMAKE_LINK_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_LINK_C): QMAKE_LINK_C = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_LINK_C_SHLIB): QMAKE_LINK_C_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
+ echo "isEmpty(QMAKE_LFLAGS): QMAKE_LFLAGS = ${OE_QMAKE_LDFLAGS}" >> $conf
+ echo "isEmpty(QMAKE_STRIP): QMAKE_STRIP = ${TARGET_PREFIX}strip" >> $conf
+
+ generate_target_qt_config_file ${D}${OE_QMAKE_PATH_BINS}/qt.conf
}
# mkspecs have mac specific scripts that depend on perl and bash