aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-11-02 11:13:33 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-11-02 11:15:16 +0200
commitec328d9677f39c223a697bbe1cbf8952631e9817 (patch)
tree02053800a6baa93715ddffaae4fcfa0b03a3d23e /recipes-qt/qt5/qtbase_git.bb
parente0db5666f9c04c92683514ca220b0aafd0a49df2 (diff)
parentd87335a50a9dd35d890786edbd79b8953fdaa11a (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.9
* qtyocto/upstream/master: qt5-ptest.inc: fix qtxmlpatterns:do_install_ptest out-of-order call meta-qt5: Update to 5.9.2 release qt5: add missing commercial license qtxmlpatterns: Add HOMEPAGE info into recipe file. qttools: Add HOMEPAGE info into recipe file. qtsvg: Add HOMEPAGE info into recipe file. qtscript: Add HOMEPAGE info into recipe file. qtquick1: Add HOMEPAGE info into recipe file. qtdeclarative: Add HOMEPAGE info into recipe file. meta: drop a useless file qtbase-native: Force use of built-in pcre qtbase-native: set path to mkspec for cmake properly again qtbase: Fix build with musl/clang qtbase: Add OE clang specific mkspecs Conflicts: recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtwebengine_git.bb Change-Id: I78ce0587cf7468bfdc22156ee8bbd24872f79c6a
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3ae2dfc1..802da3b4 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -26,6 +26,9 @@ SRC_URI += "\
file://0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
file://0007-Delete-qlonglong-and-qulonglong.patch \
file://0008-Replace-pthread_yield-with-sched_yield.patch \
+ file://0010-Add-OE-specific-specs-for-clang-compiler.patch \
+ file://0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
+ file://0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://run-ptest \
"
@@ -160,6 +163,9 @@ QT_CONFIG_FLAGS += " \
# since we cannot set empty set filename to a not existent file
deltask generate_qt_config_file
+XPLATFORM_toolchain-clang = "linux-oe-clang"
+XPLATFORM ?= "linux-oe-g++"
+
do_configure() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" during configuration
touch ${S}/mkspecs/oe-device-extra.pri
@@ -188,7 +194,7 @@ do_configure() {
-external-hostbindir ${OE_QMAKE_PATH_EXTERNAL_HOST_BINS} \
-hostdatadir ${OE_QMAKE_PATH_HOST_DATA} \
-platform ${OE_QMAKE_PLATFORM_NATIVE} \
- -xplatform linux-oe-g++ \
+ -xplatform ${XPLATFORM} \
${QT_CONFIG_FLAGS}
}