aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorKurt Kiefer <kekiefer@gmail.com>2019-05-02 11:39:39 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2019-05-02 21:28:17 +0000
commit9c62c01bc28ec8211cfa5dae16a1da58f062e805 (patch)
tree2ee93e279256164f1c66a22f733615381948a65c /recipes-qt/qt5/qtbase_git.bb
parentf4531ec860071c308725a8539ef5003da11da8a1 (diff)
qtbase-tools: Fix error during pkg_postinst
When staging the sdk, the following error is seen: sed: can't read <path-to-work>/sdk/image/usr/local/oecore-x86_64/sysroots/aarch64-oe-linux/usr/bin/qt.conf: No such file or directory because the qt.conf file moved from /usr/bin/qt.conf to /usr/bin/qt5/qt.conf This change locates the qt.conf file during pkg_postinst using the OE_QMAKE_PATH_BINS variable, just as when the file is created.
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 99adbb6b..8fb8b405 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -282,7 +282,7 @@ pkg_postinst_${PN}-tools () {
sed -i \
-e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
-e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
- $D${bindir}/qt.conf
+ $D${OE_QMAKE_PATH_BINS}/qt.conf
}
pkg_postinst_${PN}-mkspecs () {