aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-01 08:39:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2018-02-22 13:56:45 +0000
commit5250890a9f7b42a77711dfe9a3adcf86b576c2a8 (patch)
tree2f75c5d9d0a852eafe9d3b980825c41b8155e504 /recipes-qt/qt5/qtbase_git.bb
parent3f2f3a014e19ba6c23bca85b8fd1a46a85294c58 (diff)
qt5: refactor ptest
Current implementation was causing build issues as it cluttered source directories and modified recipe sysroot content. Tests are now build in the separate build directory ${B} where we don't need to worry about moving files to the recipe sysroot, and if tests are enabled in PACKAGECONFIG, they have been already built during do_compile task. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb15
1 files changed, 1 insertions, 14 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 4f3ade28..f5864096 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
@@ -29,11 +30,8 @@ SRC_URI += "\
file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
- file://run-ptest \
"
-inherit ptest
-
# LGPL-3.0 is used only in src/plugins/platforms/android/extract.cpp
# for syncqt
@@ -203,17 +201,6 @@ do_configure() {
${QT_CONFIG_FLAGS}
}
-fakeroot do_install_ptest() {
- mkdir -p ${D}${PTEST_PATH}
- t=${D}${PTEST_PATH}
- for var in ` find ${B}/tests/auto/ -name tst_*`; do
- if [ not ` echo ${var##*/} | grep '\.'` ]; then
- echo ${var##*/} >> ${t}/tst_list
- install -m 0644 ${var} ${t}
- fi
- done
-}
-
do_install_append() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri