aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-11-16 10:19:45 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-11-16 11:15:30 +0200
commit96685678ddb4adf615d037dd4c1dcca23023df19 (patch)
tree41480f2608c514cc1308445e413cfe06e9e91da3 /recipes-qt/qt5/qtbase_git.bb
parentf0ca39edb8dd0524e8822da813399cce2e70ef53 (diff)
parentff6127ddd318d422f595295d1c189a86b3032873 (diff)
Merge remote-tracking branch 'qtyocto/5.11' into 5.12
* qtyocto/5.11: ff6127d Merge remote-tracking branch 'qtyocto/upstream/master' into 5.11 6b354b9 qt5: update submodules 4064b3b qtdeclarative: fix inconsistent QML_COMPILE_HASH value fd1f0f4 python-pyqt5: Update to 5.11.3 and add python3 recipe. 3fa1993 qtbase-native: disable postgresql support 0edbe1b qtbase: refresh patches and update tags on meta-qt5 4ed4385 qtbase: don't leak absolut path to recipe specific sysroot b3502fb qt5: Disable ltcg for host_build 5832bf2 qtbase: don't use thumb for armv[45] Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtlocation_git.b b recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtpurchasing_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtscxml_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebglplugin_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb recipes-qt/qt5/qtx11extras_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Task-number: QTBUG-70847 Change-Id: I67e23c7020276516fcace20ff6a1eb698724dd22
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index bd266f78..b516f570 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.11
+# 5.11.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -29,10 +29,10 @@ SRC_URI += "\
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
- file://0015-Disable-ltcg-for-host_build.patch \
+ file://0016-Disable-ltcg-for-host_build.patch \
+ file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
"
-
# for syncqt
RDEPENDS_${PN}-tools += "perl"
@@ -172,6 +172,11 @@ deltask generate_qt_config_file
XPLATFORM_toolchain-clang = "linux-oe-clang"
XPLATFORM ?= "linux-oe-g++"
+# Causes qdrawhelper.s: Error: unaligned opcodes detected in executable segment
+# when building qtbase/5.6.3+gitAUTOINC+e6f8b072d2-r0/git/src/gui/painting/qdrawhelper.cpp
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
do_configure() {
# Regenerate header files when they are included in source tarball
# Otherwise cmake files don't set PRIVATE_HEADERS correctly