aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-02-22 13:36:16 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-02-22 13:36:16 +0200
commitc8c8613d679241b2ceac39e248a3062cc2e56ccd (patch)
treec1a47ac8b8a04a80ac98b38015f58254980fffb9 /recipes-qt/qt5/qtbase_git.bb
parent62312010bba98e2b93f24b8b9e06736f9199df9e (diff)
parentfb71293f257c6fd02ccc06765a96dbf11d4569a0 (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.12
* qtyocto/upstream/master: fb71293 qtwebengine: drop 0002-chromium_overrides.cpp-Fix-build-with-plugins-and-oz.patch 38ec325 qwt-qt5: upgrade 6.1.3 -> 6.1.4 e2d9845 qwt-qt5: Fix multilib install 5be2654 qtwebengine: Fix build with clang/libc++ on aarch64/arm cb1b472 qtbase: Export host compiler and linker 6d919b0 qt5-plugin-generic-vboxtouch: Fix build with clang/libc++ 6713882 maliit-framework,maliit-plugins: Fix build with libc++ 9a83f2d qtconnectivity: Fix build with clang/libc++ 080cc29 qtwayland: workaround upstream bug: install missing headers manually f6f61b0 gstreamer1.0-plugins-good: fix qt5 dependency d055d6a qtbase: Update the PACKAGECONFIG_KDE to enable more 82abc2b qtbase: fix incomplete recipe changes from previous commit f4c8cef qtbase: Fix qtopcua issue on bigendian systems be8bc9f qtwebkit: Disable JIT for mips64 Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtwayland_git.bb Change-Id: I4ec16ed288fda7270c59abe70d337e7016f547c7
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 6a8d2e93..74d9ee62 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.4
+# 5.12.meta-qt5-shared.5
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -64,7 +64,7 @@ LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -f
PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xcb-xinput glib xkb xkbcommon', '', d)}"
-PACKAGECONFIG_KDE ?= "${@bb.utils.contains('DISTRO_FEATURES', 'kde', 'sm cups fontconfig kms gbm libinput', '', d)}"
+PACKAGECONFIG_KDE ?= "${@bb.utils.contains('DISTRO_FEATURES', 'kde', 'sm cups fontconfig kms gbm libinput sql-sqlite accessibility openssl', '', d)}"
PACKAGECONFIG_FONTS ?= ""
PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib"
PACKAGECONFIG_DISTRO ?= ""
@@ -167,6 +167,13 @@ QT_CONFIG_FLAGS += " \
${PACKAGECONFIG_CONFARGS} \
"
+export CC_host_toolchain-clang = "clang"
+export CXX_host_toolchain-clang = "clang++"
+export LD_host_toolchain-clang = "clang++"
+export CC_host ?= "gcc"
+export CXX_host ?= "g++"
+export LD_host ?= "g++"
+
# for qtbase configuration we need default settings
# since we cannot set empty set filename to a not existent file
deltask generate_qt_config_file
@@ -240,6 +247,9 @@ do_install_append() {
echo "isEmpty(QMAKE_LINK_C_SHLIB): QMAKE_LINK_C_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
echo "isEmpty(QMAKE_LFLAGS): QMAKE_LFLAGS = ${OE_QMAKE_LDFLAGS}" >> $conf
echo "isEmpty(QMAKE_STRIP): QMAKE_STRIP = ${TARGET_PREFIX}strip" >> $conf
+ echo "isEmpty(CC_host): CC_host = ${CC_host}" >> $conf
+ echo "isEmpty(CXX_host): CXX_host = ${CXX_host}" >> $conf
+ echo "isEmpty(LD_host): LD_host = ${LD_host}" >> $conf
generate_target_qt_config_file ${D}${OE_QMAKE_PATH_BINS}/qt.conf