aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtconnectivity_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-27 23:05:26 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-20 10:49:26 +0200
commit9dc60fe10fe812eb4d722d81351c74ec598cb114 (patch)
treeaa2544f28a1e8af088ab92e8cbb9cbb490e9436e /recipes-qt/qt5/qtconnectivity_git.bb
parentd6fe20e6083d421cc6091892e1d302c46e2d075d (diff)
recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF
* this fixes builds for DISTROs which include no-static-libraries.inc * this change depends on oe-core change: http://patchwork.openembedded.org/patch/116719/ which was merged in this form: http://patchwork.openembedded.org/patch/120513/ to Yocto 2.1, if you want to use latest meta-qt5 with older oe-core you need to append EXTRA_OECONF to PACKAGECONFIG_CONFARGS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtconnectivity_git.bb')
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index cf6d3c51..17bd169f 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -18,7 +18,7 @@ inherit bluetooth
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
-EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
+EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
do_configure_prepend() {
# disable bluez test if it isn't enabled by PACKAGECONFIG