aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-05-05 12:24:20 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-05 18:27:52 +0300
commitd0266a92febaf578c4d940a97ca1f844af8384d5 (patch)
tree04f035ff57d02a7b2eb9d25b8dc6b3eca37c0f63 /recipes-qt/qt5/qtdeclarative
parent46817620916ed6d8b8f07c720f29d1faa73eafae (diff)
parent802b395222054f39501f1e02879d5c708b3da8d9 (diff)
Merge remote-tracking branch 'meta-qt5/master' into master-mingw
* meta-qt5/master: replace base_contains by bb.utils.contains qt5: upgrade to latest revision in 5.6 branch qt5: set SRCREVs,PVs to 5.6.0 qtquickcontrols: fix compilation of examples/texteditor qtdeclarative: fix compilation of examples/qquickviewcomparison quazip: update to 0.7.2 qtquickcontrols2: initial add 5.6.0 qmake5_base: use remove-libtool bbclass recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF Conflicts: classes/qmake5_base.bbclass recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtenginio_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick1_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtwayland-native_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I703197bf7b3802fa22d48a7c9eb04cfa25657c9f
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative')
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-qmltestexample-fix-link.patch5
-rw-r--r--recipes-qt/qt5/qtdeclarative/0002-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch25
2 files changed, 26 insertions, 4 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-qmltestexample-fix-link.patch b/recipes-qt/qt5/qtdeclarative/0001-qmltestexample-fix-link.patch
index b3f7621c..ee568200 100644
--- a/recipes-qt/qt5/qtdeclarative/0001-qmltestexample-fix-link.patch
+++ b/recipes-qt/qt5/qtdeclarative/0001-qmltestexample-fix-link.patch
@@ -1,4 +1,4 @@
-From 1755b8c7ab87f9e6bf072bd0bef50086c14dd9ff Mon Sep 17 00:00:00 2001
+From d26a676827ef2d64b4627090690d3240e62f6565 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Eric=20B=C3=A9nard?= <eric@eukrea.com>
Date: Sun, 26 May 2013 14:26:19 +0200
Subject: [PATCH] qmltestexample: fix link
@@ -83,6 +83,3 @@ index 1bb913e..56f2dd5 100644
CONFIG += no_import_scan
load(qt_tool)
---
-2.7.0
-
diff --git a/recipes-qt/qt5/qtdeclarative/0002-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch b/recipes-qt/qt5/qtdeclarative/0002-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch
new file mode 100644
index 00000000..60c9685f
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0002-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch
@@ -0,0 +1,25 @@
+From 9d39293e354120a9ec5e92c87b4cd695acdeb3f5 Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Thu, 31 Mar 2016 19:38:58 -0400
+Subject: [PATCH] qquickviewcomparison: fix QCoreApplication has not been
+ declared error
+
+Upstream-Status: Pending
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h b/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
+index 5b86c93..e77514e 100644
+--- a/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
++++ b/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
+@@ -44,6 +44,7 @@
+ #include <QWidget>
+ #include <QQuickWidget>
+ #include <QQuickView>
++#include <QCoreApplication>
+
+ QT_FORWARD_DECLARE_CLASS(QRadioButton)
+ QT_FORWARD_DECLARE_CLASS(QCheckBox)