aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:48:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 15:25:25 +0200
commitf8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch)
tree2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtdeclarative
parentf52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff)
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of changes in .inc files and we have only one version of modules without release (only one _git.bb) and it's impossible to find SRCREV which would be compatible with all 4 versions. * 0005-AddSynchoronization-qimagereader.patch was already backported to 5.0.2 in upstream * 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was already applied in 5.0.2 * 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in qt5-versions.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative')
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch b/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
deleted file mode 100644
index 650e603a..00000000
--- a/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 27be7a832f017653ffda705407bb7a64246eda1f Mon Sep 17 00:00:00 2001
-From: Daniel d'Andrada <daniel.dandrada@canonical.com>
-Date: Tue, 18 Dec 2012 10:51:21 -0200
-Subject: [PATCH] Flickable: Fix bug when flicking twice using touches
-
-When you flick twice in rapid succession, in the same direction,
-the expected behavior is for flickable to be moving quite fast in the
-direction of the flicks.
-
-But when you flicked using touch events instead of mouse ones,
-the second flick caused Flickable to immediately halt. This change fixes it.
-
-Upstream-Status: Backport
-
-Change-Id: I02bd02fed30bd4a98959194e04f0a26b4420cd05
-Reviewed-by: Andras Becsi <andras.becsi@digia.com>
----
- src/quick/items/qquickflickable.cpp | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/quick/items/qquickflickable.cpp b/src/quick/items/qquickflickable.cpp
-index 6e5e6b7..88ef20f 100644
---- a/src/quick/items/qquickflickable.cpp
-+++ b/src/quick/items/qquickflickable.cpp
-@@ -2038,6 +2038,11 @@ bool QQuickFlickable::sendMouseEvent(QQuickItem *item, QMouseEvent *event)
-
- QQuickWindow *c = window();
- QQuickItem *grabber = c ? c->mouseGrabberItem() : 0;
-+ if (grabber == this && d->stealMouse) {
-+ // we are already the grabber and we do want the mouse event to ourselves.
-+ return true;
-+ }
-+
- bool grabberDisabled = grabber && !grabber->isEnabled();
- bool stealThisEvent = d->stealMouse;
- if ((stealThisEvent || contains(localPos)) && (!grabber || !grabber->keepMouseGrab() || grabberDisabled)) {
---
-1.7.9.5
-