aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 14:58:06 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 21:16:50 +0200
commit48ee17af942ac9860e834c8dec049370e7802a56 (patch)
tree004e47c94682eaa418c9e718c3264ca121732102 /recipes-qt/qt5/qtdeclarative_git.bb
parent3208763b8b3f65b17825ded4b2c9b9166d78f2b2 (diff)
qt5: merge .inc and _git.bb files
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb28
1 files changed, 27 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index caa851a3..5f628c28 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -1,4 +1,30 @@
+require qt5.inc
require qt5-git.inc
-require ${PN}.inc
+
+# There are no LGPLv3-only licensed files in this component.
+LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPLv21;md5=cff17b12416c896e10ae2c17a64252e7 \
+ file://LICENSE.LGPLv3;md5=c1939be5579666be947371bc8120425f \
+ file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+DEPENDS += "qtbase"
+
+SRC_URI += " \
+ file://0001-qmltestexample-fix-link.patch \
+"
+
+PACKAGECONFIG ??= "qtxmlpatterns"
+PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
+
+do_configure_prepend() {
+ # disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG
+ sed -e 's/^\(qtHaveModule(xmlpatterns)\)/OE_QTXMLPATTERNS_ENABLED:\1/' -i ${S}/src/imports/imports.pro
+ sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro
+}
+
+EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
SRCREV = "2b3c2339616680537145a9cc2e7567575add1abb"