aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
authorAdam YH Lee <adam.yh.lee@gmail.com>2015-09-04 17:28:30 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:52 +0200
commit6f0dd9f7cb4166f22b78c0813819c636f6382e4f (patch)
tree4f179da50a054af9c93ea201f4173fc1a5d4160a /recipes-qt/qt5/qtdeclarative_git.bb
parent001ee936e9f4f3123a4f7b948bad111acdac740d (diff)
Remove double slash when QT_DIR_NAME is empty
When `QT_DIR_NAME` is defined as an empty string (default is "qt5"), package.bbclass will throw lots of QA warnings because now the paths contain double slashes ("//"). We can address these warnings by explicitly defining a slash in the variable itself. Signed-off-by: Adam YH Lee <adam.yh.lee@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 15d176b9..105c9cde 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -16,7 +16,7 @@ SRC_URI += " \
file://0001-qmltestexample-fix-link.patch \
"
-EXTRA_OEMAKE += "QMAKE_SYNCQT=${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/syncqt"
+EXTRA_OEMAKE += "QMAKE_SYNCQT=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/syncqt"
PACKAGECONFIG ??= "qtxmlpatterns"
PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
@@ -27,7 +27,7 @@ do_configure_prepend() {
sed -e 's/^\(!qtHaveModule(xmlpatterns)\)/!OE_QTXMLPATTERNS_ENABLED|\1/' -i ${S}/tests/auto/quick/quick.pro
#set the path for syncqt properly
- echo "QT_TOOL.syncqt.binary = \"${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/syncqt\"" > ${B}/.qmake.cache
+ echo "QT_TOOL.syncqt.binary = \"${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/syncqt\"" > ${B}/.qmake.cache
}
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"