aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-06-18 10:52:40 +0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-04 17:12:38 -0300
commit0263af75c053d1d7ea4882a75cf59b230fbb88ad (patch)
tree6cd09dd0835f539aac0a2aa404f4e5a3c13926d6 /recipes-qt/qt5/qtdeclarative_git.bb
parenta4f88b6b5f0703d15c4b50589d36fd6df22cd330 (diff)
qt5: add option to build Qt5 statically
Add PACKAGECONFIG that enables static build for qtbase and consequently to all Qt recipes. This can be enabled with DISTRO_FEATURE 'qt5-static', which also adds qtdeclarative-native dependency to all recipes that depend on qtdeclarative as it's required for qmlimportscannertool. Building examples and tests with static build can take excessive amounts of time and disk space, so disabling DISTRO_FEATURE 'ptest' and PACKAGECONFIGs 'examples' from qtbase is advised. Not all recipes support static builds and those are not fixed here. Change-Id: Ia0e2a2467cd42d4395ed5292a645fd1d89ad521a Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 69e90570..e6173b4e 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -14,10 +14,11 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network"
+PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}"
PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network"
+PACKAGECONFIG[static] = ",,qtdeclarative-native"
do_configure_prepend() {
# disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG