aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtscript_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 14:58:06 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 21:16:50 +0200
commit48ee17af942ac9860e834c8dec049370e7802a56 (patch)
tree004e47c94682eaa418c9e718c3264ca121732102 /recipes-qt/qt5/qtscript_git.bb
parent3208763b8b3f65b17825ded4b2c9b9166d78f2b2 (diff)
qt5: merge .inc and _git.bb files
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtscript_git.bb')
-rw-r--r--recipes-qt/qt5/qtscript_git.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 4b99e381..489be2e6 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -1,4 +1,28 @@
+require qt5.inc
require qt5-git.inc
-require ${PN}.inc
+
+# There are no LGPLv3-only licensed files in this component.
+# Note that some files are LGPL-2.1 only without Digia-Qt-LGPL-Exception-1.1.
+LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPLv21;md5=cff17b12416c896e10ae2c17a64252e7 \
+ file://LICENSE.LGPLv3;md5=c1939be5579666be947371bc8120425f \
+ file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+# qemuarm build fails with:
+# /OE/build/oe-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/qtscript/5.4.1+gitAUTOINC+822df36f25-r0/git/src/3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h: In member function 'void QTJSC::AssemblerBuffer::putInt64Unchecked(int64_t)':
+#/OE/build/oe-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/qtscript/5.4.1+gitAUTOINC+822df36f25-r0/git/src/3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:106:58: warning: cast from 'char*' to 'int64_t* {aka long long int*}' increases required alignment of target type [-Wcast-align]
+# *reinterpret_cast<int64_t*>(&m_buffer[m_size]) = value;
+# ^
+#{standard input}: Assembler messages:
+#{standard input}:22: Error: selected processor does not support Thumb mode `stmdb sp!,{r1-r3}'
+#{standard input}:23: Error: selected processor does not support Thumb mode `stmdb sp!,{r4-r8,lr}'
+#{standard input}:30: Error: lo register required -- `ldmia sp!,{r4-r8,lr}'
+#{standard input}:43: Error: lo register required -- `ldmia sp!,{r4-r8,lr}'
+ARM_INSTRUCTION_SET = "arm"
+
+DEPENDS += "qtbase"
SRCREV = "822df36f252c5a16cdf82f5666f36e7011df46c4"