aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtsystems_git.bb
diff options
context:
space:
mode:
authorJavier Viguera <javier.viguera@digi.com>2016-01-04 16:59:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:14:01 +0100
commitc7cd9cb4661dd1623368d39e66c716f2222d357b (patch)
treeb1776fd56124dd2372519a16a25b392f33323306 /recipes-qt/qt5/qtsystems_git.bb
parent511a3764506ce6bbdc5e9441a8f4e9d862ea1102 (diff)
qtconnectivity, qtsystems: fix bluetooth support
QMAKE_CACHE_EVAL is only used in qtwebengine and qtwebkit, but not in the rest of the QT5 packages, so use EXTRA_QMAKEVARS_PRE to pass the packageconfig options to the do_configure task. Also generalize bluetooth support so it can be used not only with bluez4 but with bluez5 as well. Signed-off-by: Javier Viguera <javier.viguera@digi.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtsystems_git.bb')
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 27d2bff3..9d9d245d 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -11,11 +11,14 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative udev gconf"
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[bluez4] = "OE_BLUEZ_ENABLED,,bluez4"
+inherit bluetooth
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
+
+EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
do_configure_prepend() {
- export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}"
# disable bluez test if it isn't enabled by PACKAGECONFIG
sed -i 's/^ qtCompileTest(bluez)/ OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtsystems.pro
}