aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-01-30 14:48:13 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-02 08:38:46 +0000
commitc907a6caee05b559ee231300a228f88708f9b7c2 (patch)
treea76d225332462ee3510b35faee12b304cc414f7b /recipes-qt/qt5/qttools_git.bb
parenta358108b09762390ec951f560540bb99aaf9f2a2 (diff)
qt5: refactor ptest
Current implementation was causing build issues since it cluttered source directories and modified recipe sysroot content. Tests are now built in the separate build directory ${B} where we don't need to worry about moving files to the recipe sysroot, and if tests are enabled in PACKAGECONFIG, they have been already built during do_compile. Change-Id: I8af72b0c79b3668511547dfde0fed0e3e10f2185 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 32014c88..8534b207 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
@@ -11,14 +12,11 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit ptest
-
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
# Patches from https://github.com/meta-qt5/qttools/commits/b5.10
# 5.10.meta-qt5.1
SRC_URI += " \
- file://run-ptest \
file://0001-add-noqtwebkit-configuration.patch \
file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
"
@@ -35,16 +33,9 @@ SRCREV = "3c7675d9609a15bea81884560920bded736f79a6"
BBCLASSEXTEND = "native nativesdk"
-do_compile_ptest() {
- export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH
- cd ${S}/tests
- qmake -o Makefile tests.pro
- oe_runmake
-}
-
do_install_ptest() {
mkdir -p ${D}${PTEST_PATH}
t=${D}${PTEST_PATH}
- cp ${S}/tests/auto/qtdiag/tst_tdiag $t
- cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
+ cp ${B}/tests/auto/qtdiag/tst_tdiag $t
+ cp ${B}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
}