aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-01 08:39:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2018-02-22 13:56:45 +0000
commit5250890a9f7b42a77711dfe9a3adcf86b576c2a8 (patch)
tree2f75c5d9d0a852eafe9d3b980825c41b8155e504 /recipes-qt/qt5/qttools_git.bb
parent3f2f3a014e19ba6c23bca85b8fd1a46a85294c58 (diff)
qt5: refactor ptest
Current implementation was causing build issues as it cluttered source directories and modified recipe sysroot content. Tests are now build in the separate build directory ${B} where we don't need to worry about moving files to the recipe sysroot, and if tests are enabled in PACKAGECONFIG, they have been already built during do_compile task. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 2187f9c3..dad5ba81 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
@@ -11,14 +12,11 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit ptest
-
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
# Patches from https://github.com/meta-qt5/qttools/commits/b5.10
# 5.10.meta-qt5.1
SRC_URI += " \
- file://run-ptest \
file://0001-add-noqtwebkit-configuration.patch \
file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
"
@@ -35,16 +33,9 @@ SRCREV = "3ce89dc37d3c73033c18dcec9e4710afd747ce01"
BBCLASSEXTEND = "native nativesdk"
-do_compile_ptest() {
- export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH
- cd ${S}/tests
- qmake -o Makefile tests.pro
- oe_runmake
-}
-
do_install_ptest() {
mkdir -p ${D}${PTEST_PATH}
t=${D}${PTEST_PATH}
- cp ${S}/tests/auto/qtdiag/tst_tdiag $t
- cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
+ cp ${B}/tests/auto/qtdiag/tst_tdiag $t
+ cp ${B}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
}