aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-04-12 18:20:44 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-12 16:05:30 +0200
commit5f837b47f5c3e462f24cd5abf58ff6ef1dd04932 (patch)
tree626998ad818169e1df8d08f5a67a3ac5d39b405a /recipes-qt/qt5/qttools_git.bb
parente03d290bc00105908280820d866e074440ab6f00 (diff)
qttools: add ptest
Add ptest for qttools by using provided testsuite. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index a2b01be9..5c0f51cc 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -14,9 +14,12 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+inherit ptest
+
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
SRC_URI += " \
+ file://run-ptest \
file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
file://0003-add-noqtwebkit-configuration.patch \
file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \
@@ -33,3 +36,17 @@ EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'C
SRCREV = "30c10900adecca55faa1d59c2f0caac74b1f9df6"
BBCLASSEXTEND = "native nativesdk"
+
+do_compile_ptest() {
+ export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH
+ cd ${S}/tests
+ qmake -o Makefile tests.pro
+ oe_runmake
+}
+
+do_install_ptest() {
+ mkdir -p ${D}${PTEST_PATH}
+ t=${D}${PTEST_PATH}
+ cp ${S}/tests/auto/qtdiag/tst_tdiag $t
+ cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
+}