aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland-native_git.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2014-05-12 11:41:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-30 12:48:07 +0200
commit925fcf4ecfe5f0e8f6dd76a1cf6e4b719551e493 (patch)
tree906e6efdaa5797bcb12870e3122c80b88dfa1d68 /recipes-qt/qt5/qtwayland-native_git.bb
parentbb39cdb7cc2a964d1cecd1a4109cfae50dba964b (diff)
qtwayland-native: make qtwayland find qtwaylandscanner
bindir/qt5 causes not building QtWaylandClient files. See [1] for further explanation. This error was discoverd by building hawaii-shell failing with: | /home/superandy/tmp/oe-core-eglibc/sysroots/overo/usr/include/qt5/QtCompositor/5.3.0/QtCompositor/private/qwlinputdevice_p.h:56:58: fatal error: QtCompositor/private/qwayland | #include <QtCompositor/private/qwayland-server-wayland.h> | ^ | compilation terminated. [1] https://qt.gitorious.org/qt/qtbase/commit/0e1ce36ae67de940b2d499ec7f23e520dce0f112 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwayland-native_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
index 988aa98b..b8206658 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bb
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -5,3 +5,8 @@ require ${PN}.inc
# qt5-git PV is only to indicate that this recipe is compatible with qt5 5.2.1
SRCREV = "a237778666666ab77c4e8e6b501cf0fbe7c9223e"
+
+# wayland-scanner and qtwaylandscanner must be in same path to work properly
+do_install_append() {
+ ln -sf ${D}${OE_QMAKE_PATH_QT_BINS}/qtwaylandscanner ${D}${bindir}/qtwaylandscanner
+}