aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland.inc
diff options
context:
space:
mode:
authorMikko Levonmaa <mikko.levonmaa@palm.com>2013-03-06 12:31:29 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-06 12:21:28 +0200
commitfc0b7ec73ce6aa470b6666ad115f3d0e8b83a340 (patch)
treed8eca663f908d6a2c0f6e726589703136a4c282a /recipes-qt/qt5/qtwayland.inc
parentdb7467e72a8330b0b73546ff3f68e424aeea4b1c (diff)
qtwayland: Add recipe
* Fix shader precision definition * MJ: Fix license information * MJ: Fix PV * MJ: add wayland-native to depends for wayland-scaner * MJ: add libxkbcommon to depends, but make it easy to remove it Signed-off-by: Mikko Levonmaa <mikko.levonmaa@palm.com> Signed-off-by: Martin Jansa <martin.jansa@lge.com>
Diffstat (limited to 'recipes-qt/qt5/qtwayland.inc')
-rw-r--r--recipes-qt/qt5/qtwayland.inc29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc
new file mode 100644
index 00000000..32fb08e9
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland.inc
@@ -0,0 +1,29 @@
+require qt5module.inc
+
+LICENSE = "BSD & LGPL-2.1 | GPL-3.0"
+LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenode.cpp;endline=40;md5=e38eccd7e9a6a149c9e31b6fb47daac1 \
+ file://${S}/src/compositor/compositor_api/qwaylandcompositor.cpp;endline=39;md5=8897abe415f27031e4237f09db7b9a36 \
+"
+
+# wayland-native is already in wayland DEPENDS, but add it here
+# explicitly, because it's native wayland-scanner we're looking for
+# libxkbcommon isn't mandatory with 0001-xcbcommon-should-not-be-a-mandatory-dependency.patch
+# make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't
+# have libxkbcommon in oe-core).
+XKB_DEPENDS = "libxkbcommon"
+DEPENDS += "qtdeclarative wayland wayland-native ${XKB_DEPENDS}"
+
+INC_PR = "r1"
+
+SRC_URI += " \
+ file://0001-xcbcommon-should-not-be-a-mandatory-dependency.patch \
+ file://0002-Temporarily-patching-this-out-as-Qt5.0.0-does-not-ha.patch \
+ file://0003-eglCreateImageKHR-requires-the-context-to-be-NULL.patch \
+ file://0004-EGL-Specify-vec2d-precision-qualifier-in-fragment-sh.patch \
+"
+
+QT_WAYLAND_CONFIG ?= "wayland-compositor"
+QT_WAYLAND_DEFINES ?= ""
+
+EXTRA_QMAKEVARS_PRE += "CONFIG+=${QT_WAYLAND_CONFIG}"
+EXTRA_QMAKEVARS_PRE += "DEFINES+=${QT_WAYLAND_DEFINES}"