aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-05-02 12:55:00 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-05-03 11:03:12 +0300
commit89ac66bf3969b48eb771ef4c06a0b8df00fd178a (patch)
treeb929ba359171175a23f3c10bb4ba199b00c17f4a /recipes-qt/qt5/qtwayland_git.bb
parentf087aeb1e988fcb0597fcf2b27981b1803909276 (diff)
parent8586caf2f2f5c11fb2ddff29eefe5dd7fc08cf38 (diff)
Merge remote-tracking branch 'qtyocto/upstream/warrior' into 5.12
* qtyocto/upstream/warrior: 8586caf qt5: update SRCREVs after v5.12.3 tags were downmerged to 5.12 branch 7dc422d qtwayland: check also that the destination for private headers exists before installing them 84d647a qtwayland: improve manual header installation 3d60f9a qtwayland: workaround upstream bug: install missing headers manually eb5d6da qtwayland: disable gold for all archs like in qtbase e2707a0 qt5: upgrade to 5.12.3 0778424 qtbase: disable gold for all archs not just x86 4303873 qtbase-native: use QT_CONFIG_FLAGS variable like qtbase and nativesdk-qtbase 8895ea3 qtbase: Fix build with recent oe-core/pseudo on hosts with glibc >= 2.28 95974f4 qtbase, qtmultimedia: refresh patches to apply cleanly and update them on github.com/meta-qt5 forks a4bf240 qtbase-native: add native libdir to search path adf7f60 qt5: patch build paths from installed files 28d4bfd Upgrade to 5.12.2 5a32838 layer.conf: Add warrior to compatible release series Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmqtt_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtopcua_git.bb recipes-qt/qt5/qtpurchasing_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtscxml_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebglplugin_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb recipes-qt/qt5/qtx11extras_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I085dfdddbf7915f776bd48a6d26ecf96777d9d19
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb30
1 files changed, 29 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 5f668654..36147c31 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -43,5 +43,33 @@ BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
-LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+# Since version 5.11.2 some private headers are not installed. Work around
+# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
+# further details
+QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1"
+# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2)
+SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}"
+do_install_append() {
+ if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then
+ for header in `find ${B}/src/client -name '*wayland-*.h'`; do
+ header_base=`basename $header`
+ dest="${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/$header_base"
+ if [ ! -e "$dest" ]; then
+ echo "Manual install: $header_base to $dest"
+ install -m 644 "$header" "$dest"
+ fi
+ done
+ fi
+ if [ -d "${B}/src/compositor" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/" ]; then
+ for header in `find ${B}/src/compositor -name '*wayland-*.h'`; do
+ header_base=`basename $header`
+ dest="${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/$header_base"
+ if [ ! -e "$dest" ]; then
+ echo "Manual install: $header_base to $dest"
+ install -m 644 "$header" "$dest"
+ fi
+ done
+ fi
+}