aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorDan Ackers <dan.ackers@qt.io>2021-10-18 12:11:15 +0300
committerDan Ackers <dan.ackers@qt.io>2021-10-18 13:06:32 +0300
commitf29bed63aeb4833512489a8f54297a50fee6ae46 (patch)
treeabe9b66e4376afe0df0cde33fc41e8cbc8553fc9 /recipes-qt/qt5/qtwayland_git.bb
parentbbad5a0a1981afd11489489ce668c60b41f39d25 (diff)
Merge remote-tracking branch 'warrior' into 5.12
Topics of changes that are brought in: *qtwebkit: Add patch to fix build with bison 3.7 *qtwebkit: Fix build with icu-65.1 *qtwebkit: fix build with icu >= 68 *qtwebengine: fix build with glibc-2.34 *qtwebengine: Fix build with ninja >= 1.10.0 -For now just skip version check *qtdeclarative: Ask for python3 explicitly *nativesdk-qtbase: inherit pkgconfig -some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly *qtwebkit: Inherit pkgconfig *qtgamepad: inherit pkgconfig *qtwayland: Inherit pkgconfig *qtwebengine: inherit pkgconfig *qtmultimedia: inherit pkgconfig *maliit-framework-qt5: inherit pkgconfig *qtbase: inherit pkgconfig *qt5-native.inc, nativesdk-qt5.inc, nativesdk-packagegroup-qt5-toolchain-host: reorder inherits to fix new QA check *cinematicexperience: don't use trailing slash in S *qtbase-native: disable vulkan support *qtbase: Add vulkan to PACKAGECONFIGs Conflicts: recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch recipes-qt/qt5/qtbase_git.bb Change-Id: Id4bce68abb2c2f813f16363fdec1e1d3d74bf58e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index eb158ad0..da181a15 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -1,6 +1,8 @@
require qt5.inc
require qt5-git.inc
+inherit pkgconfig
+
DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native"
DEPENDS_append_class-target = " libxkbcommon"