aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-12-01 16:46:14 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-12-09 12:22:36 +0000
commitc4a0a450b4275cc3869cf389c92e86b62f09fcea (patch)
tree6705cbb48ae3d433639bad3e78e239d210e13dee /recipes-qt/qt5/qtwayland_git.bb
parent4e113c7b8e0a7512d2f0ad306decc8b4885ef807 (diff)
qt5: update submodules
New configuration system is now used for more modules, so add new EXTRA_QMAKEVARS_CONFIGURE variable that can be used for configure modules with -[no-]feature flags. SHA1s are now from the release 5.8.0 branches, so need to add "nobranch=1" option so that there is no build break when release branches are removed. Add recipe for QtGamepad module, it's already used by Qt3D. Change-Id: I152b3b66b68c802d07445f4a7f1e81802308418e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb32
1 files changed, 13 insertions, 19 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index c64a92f1..c38d5f0c 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -16,13 +16,11 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-#FIXME: xkb should be optional; we add it here to fix the build error without it
-# (https://bugreports.qt.io/browse/QTBUG-54851)
PACKAGECONFIG ?= " \
- compositor-api \
+ wayland-client \
+ wayland-server \
wayland-egl \
- xkb \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcompositor xkb glx', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \
"
PACKAGECONFIG_class-native ?= ""
PACKAGECONFIG_class-nativesdk ?= ""
@@ -31,21 +29,17 @@ QMAKE_PROFILES_class-nativesdk = "${S}/src/qtwaylandscanner"
B_class-native = "${SEPB}/src/qtwaylandscanner"
B_class-nativesdk = "${SEPB}/src/qtwaylandscanner"
-PACKAGECONFIG[compositor-api] = "CONFIG+=wayland-compositor"
-PACKAGECONFIG[xcompositor] = "CONFIG+=config_xcomposite CONFIG+=done_config_xcomposite,CONFIG+=done_config_xcomposite,libxcomposite"
-PACKAGECONFIG[glx] = "CONFIG+=config_glx CONFIG+=done_config_glx,CONFIG+=done_config_glx,virtual/mesa"
-PACKAGECONFIG[xkb] = "CONFIG+=config_xkbcommon CONFIG+=done_config_xkbcommon,CONFIG+=done_config_xkbcommon,libxkbcommon xproto"
-PACKAGECONFIG[wayland-egl] = "CONFIG+=config_wayland_egl CONFIG+=done_config_wayland_egl,CONFIG+=done_config_wayland_egl,virtual/egl"
-PACKAGECONFIG[brcm-egl] = "CONFIG+=config_brcm_egl CONFIG+=done_config_brcm_egl,CONFIG+=done_config_brcm_egl,virtual/egl"
-PACKAGECONFIG[drm-egl] = "CONFIG+=config_drm_egl_server CONFIG+=done_config_drm_egl_server,CONFIG+=done_config_drm_egl_server,libdrm virtual/egl"
-PACKAGECONFIG[libhybris-egl] = "CONFIG+=config_libhybris_egl_server CONFIG+=done_config_libhybris_egl_server,CONFIG+=done_config_libhybris_egl_server,libhybris"
+PACKAGECONFIG[wayland-client] = "-feature-wayland-client,-no-feature-wayland-client"
+PACKAGECONFIG[wayland-server] = "-feature-wayland-server,-no-feature-wayland-server"
+PACKAGECONFIG[xcomposite-egl] = "-feature-xcomposite-egl,-no-feature-xcomposite-egl,libxcomposite"
+PACKAGECONFIG[xcomposite-glx] = "-feature-xcomposite-glx,-no-feature-xcomposite-glx,virtual/mesa"
+PACKAGECONFIG[wayland-egl] = "-feature-wayland-egl,no-feature-wayland-egl,virtual/egl"
+PACKAGECONFIG[wayland-brcm] = "-feature-wayland-brcm,-no-feature-wayland-brcm,virtual/egl"
+PACKAGECONFIG[drm-egl-server] = "-feature-drm-egl-server,-no-feature-drm-egl-server,libdrm virtual/egl"
+PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature-libhybris-egl-server,libhybris"
-EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
+EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRC_URI += " \
- file://0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch \
-"
-
-SRCREV = "3443483c9efdcfbfe049f96c83f83a5bf1d81e61"
+SRCREV = "545ef2e21d74128733f3b9b117d7c6024826cbb5"
BBCLASSEXTEND =+ "native nativesdk"