aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorJanne Kiiski <janne.kiiski@lge.com>2013-06-06 17:40:40 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-07 17:28:46 +0200
commit46626d15cde20c665f99c2564f01d3cd95cc0831 (patch)
tree55632051ba2f8ecc0444af0529a50d52e436ea58 /recipes-qt/qt5/qtwayland_git.bb
parentac8a20d754f122b8238c145ccc346cdbae1158d0 (diff)
qtwayland: Add temporary hack to build for Qt 5.0.2
* Append MODULE_VERSION to .qmake.conf if missing. * resolved in newer revision: commit 4d124fea48a0d094443ed0e031c8e28ec04611a3 Author: Oswald Buddenhagen <oswald.buddenhagen@digia.com> Date: Tue Feb 26 12:56:57 2013 +0100 Subject: define MODULE_VERSION Signed-off-by: Janne Kiiski <janne.kiiski@lge.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index b5119ec0..f91df4d5 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -7,3 +7,10 @@ PV = "4.999+5.0.0-beta1+git${SRCPV}"
PR = "${INC_PR}.1"
SRCREV = "5cb159395eccb1d96fb73a78e499eef30aacb46d"
+
+do_configure_prepend() {
+ # Temporary hack to get qtwayland build for Qt 5.0.2
+ if ! grep -q MODULE_VERSION ${S}/.qmake.conf; then
+ echo "MODULE_VERSION = 0.0.0" >> ${S}/.qmake.conf
+ fi
+}