aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-05-02 12:55:00 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-05-03 11:03:12 +0300
commit89ac66bf3969b48eb771ef4c06a0b8df00fd178a (patch)
treeb929ba359171175a23f3c10bb4ba199b00c17f4a /recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
parentf087aeb1e988fcb0597fcf2b27981b1803909276 (diff)
parent8586caf2f2f5c11fb2ddff29eefe5dd7fc08cf38 (diff)
Merge remote-tracking branch 'qtyocto/upstream/warrior' into 5.12
* qtyocto/upstream/warrior: 8586caf qt5: update SRCREVs after v5.12.3 tags were downmerged to 5.12 branch 7dc422d qtwayland: check also that the destination for private headers exists before installing them 84d647a qtwayland: improve manual header installation 3d60f9a qtwayland: workaround upstream bug: install missing headers manually eb5d6da qtwayland: disable gold for all archs like in qtbase e2707a0 qt5: upgrade to 5.12.3 0778424 qtbase: disable gold for all archs not just x86 4303873 qtbase-native: use QT_CONFIG_FLAGS variable like qtbase and nativesdk-qtbase 8895ea3 qtbase: Fix build with recent oe-core/pseudo on hosts with glibc >= 2.28 95974f4 qtbase, qtmultimedia: refresh patches to apply cleanly and update them on github.com/meta-qt5 forks a4bf240 qtbase-native: add native libdir to search path adf7f60 qt5: patch build paths from installed files 28d4bfd Upgrade to 5.12.2 5a32838 layer.conf: Add warrior to compatible release series Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmqtt_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtopcua_git.bb recipes-qt/qt5/qtpurchasing_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtscxml_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebglplugin_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb recipes-qt/qt5/qtx11extras_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I085dfdddbf7915f776bd48a6d26ecf96777d9d19
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch b/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
new file mode 100644
index 00000000..6b78f4ef
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
@@ -0,0 +1,24 @@
+From a24cb0ef3b7311719ec248f4f1771f192c7cf4a0 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 14 Dec 2017 11:28:10 +0200
+Subject: [PATCH] musl: link against libexecinfo
+
+Change-Id: Ifada60f9c72691973612850121f6fb152d70839a
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ src/core/core_module.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/core_module.pro b/src/core/core_module.pro
+index 3b5d37f2..0882d5fd 100644
+--- a/src/core/core_module.pro
++++ b/src/core/core_module.pro
+@@ -51,7 +51,7 @@ linux {
+ POST_TARGETDEPS += $$NINJA_TARGETDEPS
+
+
+-LIBS_PRIVATE += -L$$api_library_path
++LIBS_PRIVATE += -L$$api_library_path -lexecinfo
+ CONFIG *= no_smart_library_merge
+ osx {
+ LIBS_PRIVATE += -Wl,-force_load,$${api_library_path}$${QMAKE_DIR_SEP}lib$${api_library_name}.a