aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-04-17 23:32:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-04-18 23:04:41 +0000
commite2707a016c3475c167a421c9c73d88f81cc61bd1 (patch)
treee4bae2a878e4c97496dcd536af717f093c9579f2 /recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
parent07784245c1822766d54405d835ac2dc08652df1a (diff)
qt5: upgrade to 5.12.3
* be aware that in 3 qt* project the v5.12.3 tag wasn't created yet: qtknx_git.bb:# v5.12.3 tag wasn't created yet qtmqtt_git.bb:# v5.12.3 tag wasn't created yet qtopcua_git.bb:# v5.12.3 tag wasn't created yet * and qttools, qt3d, qtremoteobjects v5.12.3 tag isn't in 5.12 branch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch b/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
new file mode 100644
index 00000000..6b78f4ef
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
@@ -0,0 +1,24 @@
+From a24cb0ef3b7311719ec248f4f1771f192c7cf4a0 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 14 Dec 2017 11:28:10 +0200
+Subject: [PATCH] musl: link against libexecinfo
+
+Change-Id: Ifada60f9c72691973612850121f6fb152d70839a
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ src/core/core_module.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/core_module.pro b/src/core/core_module.pro
+index 3b5d37f2..0882d5fd 100644
+--- a/src/core/core_module.pro
++++ b/src/core/core_module.pro
+@@ -51,7 +51,7 @@ linux {
+ POST_TARGETDEPS += $$NINJA_TARGETDEPS
+
+
+-LIBS_PRIVATE += -L$$api_library_path
++LIBS_PRIVATE += -L$$api_library_path -lexecinfo
+ CONFIG *= no_smart_library_merge
+ osx {
+ LIBS_PRIVATE += -Wl,-force_load,$${api_library_path}$${QMAKE_DIR_SEP}lib$${api_library_name}.a