aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-02-15 13:15:26 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-03-01 13:05:23 +0200
commita96836aedf30d2e26fbcafc13b1313d1325a0730 (patch)
treed525675103a4ddc88c25c2303b509f71bd447f32 /recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
parente721e84659869e4a04838d95d7cdbab9d48f5c3d (diff)
parentdb881bb4917628ad3eb1fa7c4f27915cf2ae60f4 (diff)
Merge remote-tracking branch 'qtyocto/upstream/rocko' into 5.9
* qtyocto/upstream/rocko: qwt-qt5: rewrite completely qt5: upgrade to 5.9.4 qt: refresh remaining patches and tags in meta-qt5 repos qtwebengine: explicitly depend on bison-native qtlocation: correct PACKAGECONFIG for mapboxgl gstreamer1.0-plugins-bad: add expansion parameter Bump to Qt 5.9.3 Conflicts: recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch recipes-qt/qt5/qtwayland_git.bb Change-Id: I1a9a35640f301f60d8363d4c3a6bb226ea40c2d1
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch b/recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
index f1cc205b..9e3d6967 100644
--- a/recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
+++ b/recipes-qt/qt5/qtwebengine/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
@@ -1,4 +1,4 @@
-From 72a77c994434ecb708b2790ba9efaf1decc02503 Mon Sep 17 00:00:00 2001
+From c27fd437298e0d0149032be63107ab7170864513 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 16:41:23 -0700
Subject: [PATCH] chromium: musl: Adjust default pthread stack size
@@ -10,7 +10,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/chromium/base/threading/platform_thread_linux.cc b/chromium/base/threading/platform_thread_linux.cc
-index 92fbda5ee1..c41579d4ed 100644
+index 92fbda5..c41579d 100644
--- a/chromium/base/threading/platform_thread_linux.cc
+++ b/chromium/base/threading/platform_thread_linux.cc
@@ -175,7 +175,8 @@ void TerminateOnThread() {}
@@ -24,7 +24,7 @@ index 92fbda5ee1..c41579d4ed 100644
// ThreadSanitizer bloats the stack heavily. Evidence has been that the
// default stack size isn't enough for some browser tests.
diff --git a/chromium/third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp b/chromium/third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp
-index 1d164f510a..3358deb256 100644
+index 1d164f5..3358deb 100644
--- a/chromium/third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp
+++ b/chromium/third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp
@@ -68,7 +68,7 @@ size_t StackFrameDepth::getUnderestimatedStackSize() {