aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:55:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:59:12 +0100
commitb814111ed28cab46d9d896919b2b5fe308614e1d (patch)
tree09b7b2ee7a67ed0e732cc8d789499dde4b90bc8f /recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
parent1fde17e1a570aa5495ecbe8a8daae95b628db260 (diff)
qtwebengine: refresh the patches and upload them to meta-qt5 forks on github for maintenance
* fixes 0004-mkspecs-Allow-builds-with-libc-glibc.patch which didn't apply at all, because the modified mkspecs/features/configure.prf was dropped completely in: commit 047d61f188aae3fe3ebc689900b8a5c9fb6e901d Author: Michal Klocek michal.klocek@qt.io Date: Fri Aug 9 17:40:29 2019 +0200 Add webengine-core feature The same chunk can be found in src/buildtools/config/support.pri, so I've updated the .patch accordingly, but haven't tried the build with musl yet. * fixes 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch to apply ERROR: qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0 do_patch: Command Error: 'quilt --quiltrc /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0 Output: Applying patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch patching file chromium/cc/base/list_container_helper.cc Hunk #1 FAILED at 13. 1 out of 1 hunk FAILED -- rejects in file chromium/cc/base/list_container_helper.cc patching file chromium/cc/base/list_container_helper.h Hunk #1 FAILED at 8. Hunk #2 succeeded at 174 with fuzz 1. 1 out of 2 hunks FAILED -- rejects in file chromium/cc/base/list_container_helper.h Patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch does not apply (enforce with -f) ERROR: Logfile of failure stored in: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/temp/log.do_patch.21067 NOTE: recipe qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0: task do_patch: Failed ERROR: Task (/OE/build/oe-core/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_patch) failed with exit code '1' * build is still going (it will be a while on my slow builder) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch b/recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
new file mode 100644
index 00000000..34761950
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0022-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
@@ -0,0 +1,56 @@
+From 8f16cec0583c9de1ceb2c34a3bea527096f34075 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 25 Sep 2018 12:59:05 -0700
+Subject: [PATCH] chromium: musl: elf_reader.cc: include <sys/reg.h> to get
+ __WORDSIZE on musl libc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ chromium/third_party/breakpad/breakpad/configure.ac | 2 +-
+ .../breakpad/breakpad/src/common/dwarf/elf_reader.cc | 3 ++-
+ .../breakpad/breakpad/src/common/linux/elf_core_dump.h | 1 +
+ 3 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/chromium/third_party/breakpad/breakpad/configure.ac b/chromium/third_party/breakpad/breakpad/configure.ac
+index 492d09038f9..a6403ed8c3c 100644
+--- a/chromium/third_party/breakpad/breakpad/configure.ac
++++ b/chromium/third_party/breakpad/breakpad/configure.ac
+@@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32,
+ AC_HEADER_STDC
+ AC_SYS_LARGEFILE
+ AX_PTHREAD
+-AC_CHECK_HEADERS([a.out.h sys/random.h])
++AC_CHECK_HEADERS([a.out.h sys/random.h sys/reg.h])
+ AC_CHECK_FUNCS([arc4random getrandom])
+
+ AX_CXX_COMPILE_STDCXX(11, noext, mandatory)
+diff --git a/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc b/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
+index 4135a51a980..be92b792d3c 100644
+--- a/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
++++ b/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
+@@ -29,10 +29,11 @@
+ #ifndef _GNU_SOURCE
+ #define _GNU_SOURCE // needed for pread()
+ #endif
+-
++#include <config.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/mman.h>
++#include <sys/reg.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <string.h>
+diff --git a/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h b/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
+index d03c7a88d38..28b55ab6300 100644
+--- a/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
++++ b/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
+@@ -33,6 +33,7 @@
+ #ifndef COMMON_LINUX_ELF_CORE_DUMP_H_
+ #define COMMON_LINUX_ELF_CORE_DUMP_H_
+
++#include <sys/reg.h>
+ #include <elf.h>
+ #include <link.h>
+ #include <stddef.h>