aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-27 23:05:26 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-20 10:49:26 +0200
commit9dc60fe10fe812eb4d722d81351c74ec598cb114 (patch)
treeaa2544f28a1e8af088ab92e8cbb9cbb490e9436e /recipes-qt/qt5/qtwebengine_git.bb
parentd6fe20e6083d421cc6091892e1d302c46e2d075d (diff)
recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF
* this fixes builds for DISTROs which include no-static-libraries.inc * this change depends on oe-core change: http://patchwork.openembedded.org/patch/116719/ which was merged in this form: http://patchwork.openembedded.org/patch/120513/ to Yocto 2.1, if you want to use latest meta-qt5 with older oe-core you need to append EXTRA_OECONF to PACKAGECONFIG_CONFARGS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 8f5276f1..c0451747 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -40,7 +40,7 @@ PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt"
PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex"
PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx"
-EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
+EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
COMPATIBLE_MACHINE = "(-)"
COMPATIBLE_MACHINE_x86 = "(.*)"
@@ -75,7 +75,7 @@ do_configure() {
export CC_host="gcc"
export CXX_host="g++"
export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}"
- export QMAKE_CACHE_EVAL="${EXTRA_OECONF}"
+ export QMAKE_CACHE_EVAL="${PACKAGECONFIG_CONFARGS}"
# Disable autodetection from sysroot:
sed -i 's/packagesExist([^)]*vpx[^)]*):/false:/g; s/config_srtp:/false:/g; s/config_snappy:/false:/g; s/packagesExist(nss):/false:/g; s/packagesExist(minizip, zlib):/false:/g; s/packagesExist(libwebp,libwebpdemux):/false:/g; s/packagesExist(libxml-2.0,libxslt):/false:/g; s/^ *packagesExist($$package):/false:/g' ${S}/tools/qmake/mkspecs/features/configure.prf