aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-05-05 12:24:20 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-05 18:27:52 +0300
commitd0266a92febaf578c4d940a97ca1f844af8384d5 (patch)
tree04f035ff57d02a7b2eb9d25b8dc6b3eca37c0f63 /recipes-qt/qt5/qtwebengine_git.bb
parent46817620916ed6d8b8f07c720f29d1faa73eafae (diff)
parent802b395222054f39501f1e02879d5c708b3da8d9 (diff)
Merge remote-tracking branch 'meta-qt5/master' into master-mingw
* meta-qt5/master: replace base_contains by bb.utils.contains qt5: upgrade to latest revision in 5.6 branch qt5: set SRCREVs,PVs to 5.6.0 qtquickcontrols: fix compilation of examples/texteditor qtdeclarative: fix compilation of examples/qquickviewcomparison quazip: update to 0.7.2 qtquickcontrols2: initial add 5.6.0 qmake5_base: use remove-libtool bbclass recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF Conflicts: classes/qmake5_base.bbclass recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtenginio_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick1_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtwayland-native_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I703197bf7b3802fa22d48a7c9eb04cfa25657c9f
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 205193fa..bc358ef5 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -22,7 +22,7 @@ DEPENDS += " \
# qtwebengine will have additional dependencies:
# contains(QT_CONFIG, xcb): REQUIRED_PACKAGES += libdrm xcomposite xcursor xi xrandr xscrnsaver xtst
# xscreensaver isn't covered in qtbase DEPENDS
-DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}"
DEPENDS += "yasm-native"
EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm"
@@ -40,7 +40,7 @@ PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt"
PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex"
PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx"
-EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
+EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
COMPATIBLE_MACHINE = "(-)"
COMPATIBLE_MACHINE_x86 = "(.*)"
@@ -75,7 +75,7 @@ do_configure() {
export CC_host="gcc"
export CXX_host="g++"
export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}"
- export QMAKE_CACHE_EVAL="${EXTRA_OECONF}"
+ export QMAKE_CACHE_EVAL="${PACKAGECONFIG_CONFARGS}"
# Disable autodetection from sysroot:
sed -i 's/packagesExist([^)]*vpx[^)]*):/false:/g; s/config_srtp:/false:/g; s/config_snappy:/false:/g; s/packagesExist(nss):/false:/g; s/packagesExist(minizip, zlib):/false:/g; s/packagesExist(libwebp,libwebpdemux):/false:/g; s/packagesExist(libxml-2.0,libxslt):/false:/g; s/^ *packagesExist($$package):/false:/g' ${S}/tools/qmake/mkspecs/features/configure.prf
@@ -119,8 +119,8 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "4ed08bb0a8195746c333dabbdb9da3400d174296"
-SRCREV_chromium = "0a385bb01d9cf060fae4c9d350ee98561654df96"
+SRCREV_qtwebengine = "643aa579fc94933eefa8eb20af6729e2140cf480"
+SRCREV_chromium = "8252b18aa3efa52138e91f9756945afb142a1c8c"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"