aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-22 09:14:48 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-22 12:47:16 +0200
commitddbe177dae46353f08f7326a11d3b3fd5a1f8435 (patch)
tree89ceddbc93150e1d6fe7dccb15fea1ec59b3c839 /recipes-qt/qt5/qtwebengine_git.bb
parent72ac998cef3306e6e4d2f3760af1c21cedfc330f (diff)
parent52b0e06d02e7f43cf54f447e0487c40c2c1fed00 (diff)
Merge remote-tracking branch 'meta-qt5/master' into master-mingw
* meta-qt5/master: qttransltations: Add PACKAGE for qtwebengine and qtquickcontrols2 qtwebengine: Hide textrel QA warning until there is proper fix for it qtwebengine: Fix QA warning qtwebkit: Fix QA Warning examples: fix few thousands host-user-contaminated QA warnings qtbase: Don't install libQt* files twice qtbase: Resolve QA warning about /bin/bash dependency qtbase: Fix WORKDIR references in pkg-config files qt5: upgrade to latest revisions in 5.6 branch (5.6 RC) qmake5_base: delete *.la files qt5: add Qml support to lupdate qt3d: support qgltf in native and nativesdk builds qt5: use common PACKAGECONFIG to build examples qt5-git.inc: Ensure we export the SRCREV as the module name qtbase: Fix installation of fonts and libraries Conflicts: classes/qmake5_base.bbclass recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtenginio_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick1_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qtsystems_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtwayland-native_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I0a7763f973c32df796cb3e37c753ddbfe43c4521
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 8375fec7..0557ec7f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -92,6 +92,7 @@ do_configure() {
do_install_append() {
rmdir ${D}${OE_QMAKE_PATH_PLUGINS}/${BPN} ${D}${OE_QMAKE_PATH_PLUGINS} || true
+ sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@-L${B}[^ ]* @ @g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc
}
PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
@@ -110,10 +111,10 @@ SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \
file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
+ file://0004-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
+ file://0005-Include-dependency-to-QCoreApplication-translate.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
- file://0002-media_capture_devices_dispatcher.h-Include-QCoreApplication-translate.patch \
- file://0003-WebEngine-qquickwebengineview_p_p.h-add-inc-QColor.patch \
- file://0001-chromium-jpeg_codec.cc_Change-false-to-FALSE-and-1-to-TRUE.patch \
+ file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
SRCREV_qtwebengine = "87cc80fd8182b24ff42f0f5458cb82f139730536"
@@ -123,3 +124,6 @@ SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
S = "${WORKDIR}/git"
+
+# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel]
+INSANE_SKIP_${PN} += "textrel"