aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-08-15 16:03:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-08-15 16:03:28 +0000
commitcb7dfcc53adc3e7136f1a8d23bb6252a71027ed8 (patch)
treedafb9283fc5cccfd3dd121927f5be2d93c883b7d /recipes-qt/qt5/qtwebengine_git.bb
parent70b090a50468edd0dd20788d8c7828e792e0f8dc (diff)
qtwebengine: Add PACKAGECONFIG for pepper-plugins printing-and-pdf spellchecker
* also add libpci runtime dependency for x86 targets (imported from meta-luneui) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 4a75d9b1..5b6e50e3 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -59,6 +59,9 @@ PACKAGECONFIG[jasoncpp] = "-feature-webengine-system-jsoncpp,-no-feature-webengi
PACKAGECONFIG[libxml2] = "-feature-webengine-system-libxml2,-no-feature-webengine-system-libxml2,libxml2"
PACKAGECONFIG[minizip] = "-feature-webengine-system-minizip,-no-feature-webengine-system-minizip,minizip"
PACKAGECONFIG[proprietary-codecs] = "-feature-webengine-proprietary-codecs,-no-feature-webengine-proprietary-codecs"
+PACKAGECONFIG[pepper-plugins] = "-feature-webengine-pepper-plugins,-no-feature-webengine-pepper-plugins"
+PACKAGECONFIG[printing-and-pdf] = "-feature-webengine-printing-and-pdf,-no-feature-webengine-printing-and-pdf"
+PACKAGECONFIG[spellchecker] = "-feature-webengine-spellchecker,-no-feature-webengine-spellchecker"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
@@ -120,6 +123,9 @@ PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
# for /usr/share/qt5/qtwebengine_resources.pak
FILES_${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}"
+# Chromium uses libpci to determine which optimizations/workarounds to apply
+RDEPENDS_${PN}_append_x86 = " libpci"
+
RDEPENDS_${PN}-examples += " \
${PN}-qmlplugins \
qtquickcontrols-qmlplugins \