aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-01-16 12:47:51 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-01-16 14:21:42 +0000
commitce766374432309b85fdcfe8ef287dbb2ef11b337 (patch)
treef82903a0c4d5519c6f2fb8e1a83758dc6e450705 /recipes-qt/qt5/qtwebengine_git.bb
parent229f819b97e653399455e7b1d491de5ea49d5ba5 (diff)
qt: refresh remaining patches and tags in meta-qt5 repos
* update tag name to match the patches in meta-qt5 repository where the meta-qt5 .patch files are maintained, so that it's more clear from where these changes are exported (with: git format-patch --no-numbered --no-signature) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb50
1 files changed, 26 insertions, 24 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 3a6a37e2..dcb81747 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -123,38 +123,40 @@ RDEPENDS_${PN}-examples += " \
QT_MODULE_BRANCH_CHROMIUM = "61-based"
-# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.9
-# 5.9.meta-qt5.3
+# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.10
+# 5.10.meta-qt5.1
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
- file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
- file://0003-Include-dependency-to-QCoreApplication-translate.patch \
- file://0004-Force-host-toolchain-configuration.patch \
+ file://0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
+ file://0002-Include-dependency-to-QCoreApplication-translate.patch \
+ file://0003-Force-host-toolchain-configuration.patch \
+"
+SRC_URI_append_libc-musl = "\
+ file://0004-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
+ file://0005-musl-link-against-libexecinfo.patch \
"
-# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based
-# 56-based.meta-qt5.2
+# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/61-based
+# 61-based.meta-qt5.1
SRC_URI += " \
- file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
- file://0003-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
+ file://0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
+ file://0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\
- file://0005-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
- file://0006-musl-link-against-libexecinfo.patch \
- file://0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
- file://0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
- file://0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
- file://0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
- file://0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
- file://0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
- file://0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
- file://0011-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \
- file://0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
- file://0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
- file://0014-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
- file://0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
- file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
+ file://0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
+ file://0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
+ file://0005-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
+ file://0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
+ file://0007-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
+ file://0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
+ file://0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
+ file://0010-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \
+ file://0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
+ file://0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
+ file://0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
+ file://0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
+ file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
SRCREV_qtwebengine = "efa6d3f0d3a01753dd40823ce119e7d4f9765c8e"