aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-08 18:15:47 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-10 13:09:35 +0100
commit324843cb1a2feb5f5c7b0064ca33edaa605cb749 (patch)
tree2a5281fbf59573b844fa7aad9d9851bba95bde5a /recipes-qt/qt5/qtwebkit
parenta1981938c245473f08f0531fc4c821cb67d26296 (diff)
qtwebkit: Fix build with gcc11/riscv
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit')
-rw-r--r--recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch b/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch
new file mode 100644
index 00000000..39ee847c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch
@@ -0,0 +1,23 @@
+link with libatomic
+
+This fixes build with C11
+
+lib/../Source/WTF/wtf/CMakeFiles/WTF.dir/Assertions.cpp.o:/usr/include/c++/11.0.1/bits/atomic_base.h:520: more undefined references to `__atomic_compare_exchange_1' follow
+| collect2: error: ld returned 1 exit status
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WTF/wtf/CMakeLists.txt
++++ b/Source/WTF/wtf/CMakeLists.txt
+@@ -245,6 +245,10 @@ if (NOT USE_SYSTEM_MALLOC)
+ list(APPEND WTF_LIBRARIES bmalloc)
+ endif ()
+
++list(APPEND WTF_LIBRARIES
++ -Wl,--as-needed -Wl,-latomic -Wl,--no-as-needed
++)
++
+ list(APPEND WTF_SOURCES
+ unicode/icu/CollatorICU.cpp
+ )