aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-01-15 10:19:24 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-01-15 10:20:17 +0200
commitf29e5bf1d15372a21e3e79a23afbc2be9fbaa004 (patch)
treeb2256fc1ebc713c8d51897eb46116b35d28551e9 /recipes-qt/qt5/qtwebkit_git.bb
parent07393133a7c0c27c71a24da5ec09834281fd0f13 (diff)
parentf6ebff397a53e9c2a23f67d1fc74b5fed11df4f9 (diff)
Merge remote-tracking branch 'qt/5.14' into 5.15
* qt/5.14: f6ebff39 Merge remote-tracking branch 'qt/upstream/master' into 5.14 1b8e5570 qtbase: Use pcre packages by default fd7ac089 qt5: use PACKAGECONFIG to disable tests and examples 1a7c8fa4 qtlocation: use geoclue 2 ddbf8dd0 qtbase: use offscreen platform plugin for tools 4f701ea1 qtbase: add openssl PACKAGECONFIG for native nativesdk 56b2c13d qtbase-native: disable vulkan support 6b34fd17 maliit-framework-qt5: fix test installations aa50163c qtenginio: remove obsolete module 32edd746 ogl-runtime: update to v2.5.0 release f7dcc706 qtquick3d: add recipe b814111e qtwebengine: refresh the patches and upload them to meta-qt5 forks on github for maintenance 1fde17e1 qtbase: refresh the patches and upload them to meta-qt5 forks on github for maintenance ca649e3f qt5: Update to Qt 5.14.0 ede15adc qtbase: Fix patch fuzz detected with devtool e8221c2c qtbase: Backport the patch from upstream gerrit ca2f53f9 qt5-creator: Update musl patch to link qmldesigner with -lexecinfo 6e7cc682 qtwebengine: Move CharAllocator definition to header 33a86256 qt5-creator: Add missing dep on libz.so 3d47a569 qt5-creator: Make clang-format patch work with multiple clang versions d8f0db7f qtwebengine: Include cstddef for size_t definition b6bd407e qmllive: Fix build with multilib settings 69e1fd33 quazip: Fix multilib builds a4db065b qtwebkit: Fix linking errors on clang/mips/ppc f756a065 ogl-runtime: Only compile for supported architectures 710d995b qttools: Add option to disable qdoc a02e01ca qttools: Use CONFIG+=disable_external_rpath 0d88f448 packagegroup-qt5-toolchain-target: Make machine specific 2a2055fa recipes: Disable clang dependent recipes for riscv64/32 Conflicts: recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch Change-Id: Ie1c25965f512eccade0a7518b3a2d23c6dc6b3c1
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 53f3043e..41c7b173 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -49,9 +49,13 @@ EXTRA_OECMAKE += " \
EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}'"
-# JIT not supported on MIPS64
-EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
-EXTRA_OECMAKE_append_mips64el = " -DENABLE_JIT=OFF "
+# JIT not supported on MIPS/PPC
+EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
+EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
+# Disable gold on mips64/clang
+# mips64-yoe-linux-musl-ld.gold: internal error in get_got_page_offset, at ../../gold/mips.cc:6260
+# mips-yoe-linux-musl-ld.gold: error: Can't find matching LO16 reloc
+EXTRA_OECMAKE_append_toolchain-clang_mipsarch = " -DUSE_LD_GOLD=OFF "
PACKAGECONFIG ??= "qtlocation qtmultimedia qtsensors qtwebchannel \
${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \