aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-18 15:55:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-20 14:45:14 +0100
commit1fea2d7b4c5239463ce65f90f84221221b08f250 (patch)
tree36401c6b0971c0fd78486e6e1dc1698968060013 /recipes-qt/qt5/qtwebkit_git.bb
parent7f8c441d96a61980d272eb7a2a7481e173286f72 (diff)
qtwebkit: Fix QA Warning
* there are multiple -L paths to workdir, causing QA warning like this: ERROR: qtwebkit-5.5.99+5.6.0-rc+gitAUTOINC+d2ff5a0855-r0 do_populate_sysroot: QA Issue: Qt5WebKit.pc failed sanity test (tmpdir) in path qtwebkit/5.5.99+5.6.0-rc+gitAUTOINC+d2ff5a0855-r0/sysroot-destdir//usr/lib/pkgconfig [pkgconfig] * qtwebkit is dead, so hack it with simple sed, feel free to fix it in mkspecs if you want Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 559efacb..9044d4fb 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -56,6 +56,12 @@ do_configure_prepend() {
QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0"
EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}"
+do_install_append() {
+ # Remove paths to workdir, qtwebkit is dead now, so I won't spend extra time trying to prevent this
+ # from some .prl or .prf file like for other modules
+ sed -i 's@-Wl,-no-whole-archive -L${B}[^ ]* @ @g' ${D}${libdir}/pkgconfig/Qt5WebKit.pc
+}
+
# remove default ${PN}-examples* set in qt5.inc, because they conflicts with ${PN} from separate webkit-examples recipe
PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples"